Jump to content

Php Error Breaking Workflow

Recommended Posts

  • What you were doing when the issue happened
    • I noticed this issue while using the Calculate Anything workflow. I try to use the workflow and it seems an error is stopping the workflow from showing the response in the Alfred Input window.
    • I was using the Calculate Anything workflow from the Alfred Gallery: https://alfred.app/workflows/biatidigital/calculate-anything/
    1. Specific steps to repo:
    2. Open workflow and debugger
    3. Open Alfred input
    4. Type '5lbs to oz'
    5. See error
  • Whether you were able to replicate it a second time by performing the same action (Update any third-party apps and restart your Mac if relevant)
    • Yes
  • Include any screenshots that might help us
    • Notable error in Debugger:
      • [15:05:31.432] ERROR: Calculate Anything[Script Filter] JSON error: JSON text did not start with array or object and option to allow fragments not set. around line 1, column 0. in JSON:
        Warning: Failed loading Zend extension 'xdebug.so' (tried: /opt/homebrew/lib/php/pecl/20220829/xdebug.so (dlopen(/opt/homebrew/lib/php/pecl/20220829/xdebug.so, 0x0009): tried: '/opt/homebrew/lib/php/pecl/20220829/xdebug.so' (no such file), '/System/Volumes/Preboot/Cryptexes/OS/opt/homebrew/lib/php/pecl/20220829/xdebug.so' (no such file), '/opt/homebrew/lib/php/pecl/20220829/xdebug.so' (no such file)), /opt/homebrew/lib/php/pecl/20220829/xdebug.so.so (dlopen(/opt/homebrew/lib/php/pecl/20220829/xdebug.so.so, 0x0009): tried: '/opt/homebrew/lib/php/pecl/20220829/xdebug.so.so' (no such file), '/System/Volumes/Preboot/Cryptexes/OS/opt/homebrew/lib/php/pecl/20220829/xdebug.so.so' (no such file), '/opt/homebrew/lib/php/pecl/20220829/xdebug.so.so' (no such file))) in Unknown on line 0


    • https://gist.github.com/jelias/66f4901928440220c30546368d39a024
    • Additional Details in (Closed) GH Issue https://github.com/biati-digital/alfred-calculate-anything/issues/127
  • Include the Alfred version & build number you are using
    • Alfred 5.1.2 - Build 2145, Wednesday 2nd August 2023
  • Include your macOS version
    • MacOS 13.5 (M2 Max)
  • Include the version number of any third-party apps relevant to your issue
    • Calculate Anything 4.0.2 (from the Gallery)


  • Additional Notes:
    • I have multiple installations of PHP, and I use Xdebug for work. It works fine in other projects. I'm not sure why it cannot be found in the php version that Alfred is using. But either way, it shouldn't be what is breaking Calculate Anything—I'm confused what is.
Edited by Boarder24
Link to comment

The error you’re facing is not related to Alfred, which only runs PHP from whatever place is specified in the workflow. PHP is external to Alfred and if you have an atypical setup (seems to be the case) it’s there where it needs to be fixed. Try searching for your error online. In addition, read Understanding the Scripting Environment for clues, it’s possible that your environment (lack of it) is causing the problem.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...