Jump to content

Zsh adds symbols that breaks "script filter" and "run script"

Recommended Posts

I am not sure if this is alfred problem per se, but i have it all the time with zsh

- What you were doing when the issue happened

When i am writing workflows or using third party workflows from alfred gallery or downloaded manually, workflow doesn't work if it is using `zsh` as specified language


Whether you were able to replicate it a second time by performing the same action

Yes zsh is not working, when i change language to `bash` it works fine


Include any screenshots that might help us

here is example log from workflow debug

[11:07:49.028] ChatFred[Script Filter] �]697;OSCLock=��]697;PreExec�{"variables": {"user_prompt": ""}, "items": [{"type": "default", "title": "...", "subtitle": "Talk to ChatGPT \ud83d\udcac", "arg": ["b6e56e82-b905-11ee-b71d-7ea1a542d15e", "..."], "autocomplete": "...", "icon": {"path": "./icon.png"}}]}
[11:07:49.029] ERROR: ChatFred[Script Filter] JSON error: JSON text did not start with array or object and option to allow fragments not set. around line 1, column 0. in JSON: 

and here is how node looks like



If i change language to bash - it works fine


Include the Alfred version & build number you are using

Alfred version - 5.1.4


Include your macOS version

Mac os version - 13.6.3




Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...