Jump to content

1Password workflow has multiple copies / double entries

Recommended Posts

Hello, I updated the 1Password workflow from the Alfred Gallery. It installed a second workflow in the Workflows list (and the 1Password integration did not work, mostly error messages that the 1Password CLI is not installed, but it was/is). I tried to delete the second workflow entry, but it comes back. As of now, I have even three of them (see screenshot). One is version 2023.6, two of them are 2023.12 (corresponds to the workflows' icon). Currently, the 1Password workflow seems to work (but which one?).


How can I delete the superfluous workflows? I tried to delete them (by clicking the "minus" button; they disappear first, but, as I said, they "come back"), re-start Alfred, re-start 1Password (app).


Alfred version: 5.5 [2257]

1Password version: 8.10.30

macOS version: 14.4.1 (Sonoma)



CleanShot 2024-04-18 at 14.11.26.png

Link to comment

@hogru Welcome to the forum. 


Could you please let me know which sync service you're using for your preferences? You can check in Alfred's Advanced tab if you don't recall, as you'll see the path to your synced preferences.


You'll need to ensure that the sync service is set to keep your Alfred preferences offline, as Alfred needs constant access to the preferences, so you may see this kind of behaviour if this isn't the case:



Once you've set your preferences as being saved offline, you should be able to delete the superfluous workflows. Let me know how you get on :)



Edited by Vero
Thread moved to Workflows Help & Questions
Link to comment

Hello Vero,


I use iCloud and "Optimize Mac Storage" was/is turned off (see screenshot).


The path to the preferences file is "/Users/stephan/Library/Mobile Documents/com~apple~CloudDocs/Apps/Alfred/Alfred.alfredpreferences".

In Alfred's prefs.json, there were TWO identical syncfolders entries to that folder (see below).


  "current" : "\/Users\/stephan\/Library\/Mobile Documents\/com~apple~CloudDocs\/Apps\/Alfred\/Alfred.alfredpreferences",
  "syncfolders" : {
    "4" : "~\/Library\/Mobile Documents\/com~apple~CloudDocs\/Apps\/Alfred",
    "5" : "~\/Library\/Mobile Documents\/com~apple~CloudDocs\/Apps\/Alfred"


I then followed the steps here to disable syncing, with the idea to disable syncing, get rid of the additional workflows and enable syncing again. That seems to have worked.

So, after a bit of work, it seems to be resolved.


Thanks for the hint with the syncing. That somehow seemed to be the culprit.


CleanShot 2024-04-18 at 14.47.26.png

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...