Jump to content

Send Chrome tab to Safari's Reading List

Recommended Posts

I use Chrome on my desktop, but I like to do all of my reading on my iPad or iPhone and I like using the Reading List built into Safari. I've used Pocket for this before, but a lot of stuff ends up in Safari's Reading List when I'm using the Twitter client on iOS. This workflow will take your current Chrome tab and send it to Safari's Reading List.




Installation Instructions


From a terminal window, run:

sudo gem install rb-appscript

Download the workflow from:








Type `rl` in Alfred





Script copied from:


Link to comment
  • 1 month later...

I followed all of the above instructions and got this error:


MyName-Air:~ MyName$ sudo gem install rb-appscript
Fetching: rb-appscript-0.6.1.gem (100%)
Building native extensions.  This could take a while...
ERROR:  Error installing rb-appscript:
ERROR: Failed to build gem native extension.
    /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby extconf.rb
mkmf.rb can't find header files for ruby at /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/include/ruby.h
Gem files will remain installed in /Library/Ruby/Gems/2.0.0/gems/rb-appscript-0.6.1 for inspection.
Results logged to /Library/Ruby/Gems/2.0.0/gems/rb-appscript-0.6.1/./gem_make.out
MyName-Air:~ MyName$ 
When I enter Alfred it doesn't find the command "rl"
Any help appreciated !!
Link to comment
  • 2 weeks later...

I am sorry but since I am new to this, and especially coding in general, what am I supposed to do with the last string you posted as a fix to the above problem?

Tried copy pasting into the terminal both from the beginning and after I got the same error as above.

Help much appreciated, cause it's a very useful bathroom break workflow, thanks!

Link to comment
  • 3 months later...

Hi there,


I'm getting the following require error when I try to use this script;

[ERROR: alfred.workflow.action.script] Code 1: /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- appscript (LoadError)
from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from -e:4:in `<main>'

Anyone got a suggestion on how to fix this? I ran the install of appscript and everything seemed to go ok.




Link to comment
  • 4 weeks later...
  • 3 months later...
  • 3 months later...
  • 2 weeks later...
which version of ruby and which version of bundler will this work with?
I have installed ruby through rbenv as opposed to RVM, is that an issue?
the error reads as follows:

ERROR:  Loading command: install (LoadError)
dlopen(~/.rbenv/versions/2.1.3/lib/ruby/2.1.0/x86_64-darwin13.0/openssl.bundle, 9): Symbol not found: _SSLv2_client_method
  Referenced from: ~/.rbenv/versions/2.1.3/lib/ruby/2.1.0/x86_64-darwin13.0/openssl.bundle
  Expected in: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib
 in ~/.rbenv/versions/2.1.3/lib/ruby/2.1.0/x86_64-darwin13.0/openssl.bundle - ~/.rbenv/versions/2.1.3/lib/ruby/2.1.0/x86_64-darwin13.0/openssl.bundle
ERROR:  While executing gem ... (NoMethodError)
    undefined method `invoke_with_build_args' for nil:NilClass



Edited by dipanjanc
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...