Jump to content

Alternate keyboard layout force doesn't work


bezdnaskov
 Share

Recommended Posts

The same issue.

 

Vero said:

Hi there, have a look at this knowledge base entry for details on using OS X input sources with Alfred when you have multiple keyboard languages/layouts available:

http://support.alfre...board-languages

Let me know if you still have any issues  :)

 

Please, watch this video to recognize bug:

 

Keyboard force doesn't work immediately after turning on the computer. But when I go to the settings and refresh force option, it works. 

Link to comment
Share on other sites

Keyboard force doesn't work immediately after turning on the computer. But when I go to the settings and refresh force option, it works. 

 

As per the support page, make sure that when you go to the Keyboard > Input Sources, you ensure that the checkbox for "Automatically switch to a document's input source" is unchecked. I can see in your screencast that the box is still checked. Alfred will then use the "Force Keyboard" language you picked. :)

Link to comment
Share on other sites

  • 5 months later...

I have this same problem, but my "automatically switch" checkbox is not checked. What I do have is that I had Colemak as my only input source for a while, and when I added the English standard input source, the Alfred pop up box would swap input sources uses on every other use. I opened Alfred, found the Force Input setting to be blank, I chose Colemak and found that it forced the popup into the opposite (EN) input source, and vice versa when I set the force to EN. It certainly feels like some code is struggling to honor the sorting of the OS input settings.

Link to comment
Share on other sites

I have this same problem, but my "automatically switch" checkbox is not checked. What I do have is that I had Colemak as my only input source for a while, and when I added the English standard input source, the Alfred pop up box would swap input sources uses on every other use. I opened Alfred, found the Force Input setting to be blank, I chose Colemak and found that it forced the popup into the opposite (EN) input source, and vice versa when I set the force to EN. It certainly feels like some code is struggling to honor the sorting of the OS input settings.

 

Hi Tim,

 

What is the behaviour you want? Do you want:

 

A. For Alfred to respect the keyboard/language you've set globally? (e.g. if you're currently using your Mac in Colemak, use Colemak, if you're using your Mac in English Standard, it uses English standard too)

 

or 

 

B. For Alfred to always use one specific keyboard/language, no matter what you're using elsewhere on your Mac? (e.g. Alfred should stick to English Standard, no matter whether OS X is set to Colemak or English at that time)

 

This will help me reproduce what you're seeing, and see whether there is an issue. If there isn't, then I can help you set your Mac up for the setup you prefer.

 

Cheers, :)

Vero

Link to comment
Share on other sites

  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...