Jump to content

Force Keyboard option not working w/ custom layouts


dreikanter
 Share

Recommended Posts

I'm using Alfred 2.5.1 on OS X Yosemite.

 

I have two custom keyboard layouts (https://yadi.sk/i/9tQbC6SycMzSe), and want the English one to appear in Alfred command line by default. This layout is enabled in configuration (https://yadi.sk/i/aKxSXfrjcMyZa), but Alfred not actually forcing it: https://yadi.sk/i/tdzN76uCcMzb7

 

Here is the layout: http://ilyabirman.net/projects/typography-layout/

Edited by dreikanter
Link to comment
Share on other sites

I'm using Alfred 2.5.1 on OS X Yosemite.

 

I have two custom keyboard layouts (https://yadi.sk/i/9tQbC6SycMzSe), and want the English one to appear in Alfred command line by default. This layout is enabled in configuration (https://yadi.sk/i/aKxSXfrjcMyZa), but Alfred not actually forcing it: https://yadi.sk/i/tdzN76uCcMzb7

 

Here is the layout: http://ilyabirman.net/projects/typography-layout/

 

Have you taken a look at this page? There are a few key settings to check in System Preferences as well as in Alfred's prefs to ensure the choice of language is respected:

http://support.alfredapp.com/kb:keyboard-languages

 

I haven't yet updated the page for Yosemite, so the location or exact wording of the settings may be slightly different, but the idea is the same. Let me know if you have any issues, and I'll make sure I update this page for Yosemite very shortly too :)

Link to comment
Share on other sites

Have you taken a look at this page? There are a few key settings to check in System Preferences as well as in Alfred's prefs to ensure the choice of language is respected:

http://support.alfredapp.com/kb:keyboard-languages

 

I haven't yet updated the page for Yosemite, so the location or exact wording of the settings may be slightly different, but the idea is the same. Let me know if you have any issues, and I'll make sure I update this page for Yosemite very shortly too :)

 

I've checked "Automatically switch", and it was already disabled.

 

I've tried to disable layout forcing option, than set it to Russian (it was English before, and I need English). And it started to work. I've switched back to English, and now I have it working the way I need.  Looks like the setting was saved before, but was not applied somehow.

 

Thanks anyway :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...