Jump to content

Incorrect focus when using Alfred Clipboard with Chrome [Fixed 2.7.2 b400]


znelson7
 Share

Recommended Posts

Hello,

 

I use the Alfred Clipboard ring extensively and have been running into a lot of issues recently with it.  When I use the clipboard, navigate to an entry I want, press Enter to select the entry focus is returned to the wrong window.

 

Steps:

  1. Open multiple Profiles in Google Chrome (I have 3 profiles)
  2. Click into an editable area in one of the browser windows
  3. Use the hotkey to bring up the Alfred Clipboard
  4. Select an entry and press Enter

Result: Frequently focus will be returned to the wrong window and the text will be pasted to the wrong place.

 

I would expect focus to be returned to the active window that I had previously open.  This used to only happen sporadically, but now happens all the time.  Also, try focusing on multiple windows across multiple monitors.  I run a two-monitor setup.

 

Thanks!

-Zack

Link to comment
Share on other sites

This used to only happen sporadically, but now happens all the time.  Also, try focusing on multiple windows across multiple monitors.  I run a two-monitor setup.

 

This is something that I'm aware of and something which has been getting progressively worse with newer versions of OS X.

 

You can reproduce this behaviour without Alfred... With a Safari window on your primary screen and a Safari and Chrome window on your secondary screen, select the Safari window on your second screen, then Chrome, then cmd+tab back to Safari and it selects the incorrect Safari window (same behaviour you are seeing in Alfred).

 

I am working on something which should hopefully significantly improve this behaviour in the next release :)

 

Cheers,

Andrew

 

[marked as accepted]

Link to comment
Share on other sites

  • 1 month later...

I use the Alfred Clipboard ring extensively and have been running into a lot of issues recently with it.  When I use the clipboard, navigate to an entry I want, press Enter to select the entry focus is returned to the wrong window.

 

This should now be fixed in the 2.7.2 b400 pre-release, available in Alfred's update prefs :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...