Jump to content

Shell Script for Rumember - RTM Addon

Recommended Posts

I am going a little nuts, I know I must be doing something wrong (since its not working) but I can't figure it out.


I installed and configured Rumember - from terminal executing:


ru pick up the milk ^Today #Personal


works just fine and adds to RTM.


I have then setup a workflow in Alfred that on typing 'r {query}' it would execute a shell script.  I tried to different methods to get this to work:



ru {query}


shopt -s expand_aliases

if [ -f "${HOME}/.bash_profile" ] ; then
	source "${HOME}/.bash_profile"

ru {query} &


Neither method works, no errors , nothing in bash history just blank.


Any help would be great!



Link to comment

I tested the same script (method 2) in console script worked flawlessly.


No errors are showing up - unless there is a debug for alfred I can see?


Also i even tried to just execute a command in the script say:


ru "test adding to milk manually"


and that doesn't work.


I have tried with all the different options on escaping none seem to work, here is my setup:





I am pretty sure I am doing something wrong just wish I knew what it was :D

Link to comment

Why don't you post your workflow here? It'll probably be something really obvious (like have you actually linked the keyword input to the script?) and you'll want to bang your head on your desk. :o No offence intended, you should see some of my "D'oh!" moments. :lol:

Link to comment
  • 3 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...