Jump to content

alfred-chrome - Open URL in Google Chrome (also with specific profile)

Recommended Posts

  • 1 month later...
  • 2 weeks later...
  • 1 year later...
  • 1 year later...
17 hours ago, Damien Cuvillier said:

Nice workflow I use for months now. 

But .. MacOS BigSur has come and now, it does not work anymore. 



I've tried to chmod +x on linked file, but nothing changes.. 

Hi, @Damien Cuvillier

I'm also running macOS Big Sur.

I tried the following steps to reproduce the issue but it worked fine: 

  1. Removed the Chrome Incognito workflow
  2. Downloaded it from this Packal link 
  3. Installed it by clicking on the downloaded file
  4. Triggered the workflow using Alfred

It worked afterwards. Could you try this as well?

Link to comment
  • 3 months later...

For those who absolutely must to have some shortcuts to open different Chrome profiles but can't use this Workflow extension, here is a little something that is very minimal but helps me navigate through my profile.

You can create your own Alfred workflow, that triggers by an input with arguments.

Link this trigger to a "Run Script Action" object.

Configure the Script Action with the following snippet:

/Applications/Google\ Chrome.app/Contents/MacOS/Google\ Chrome --args --profile-directory="Profile $query"

This will take your first argument of the commend and append it to the "Profile " word.


Now, I have list of profiles in my chrome that I would like to open. I simply associate them with numbers in my head (I don't have that much).

To help you find the number of the profile, or as a matter of fact, an actual identifier of the profile in case you have something different that just Profile #number

Open your Chrome profile, type in search bar "chrome://version" 

You will find the profile name and its path by:

Profile Path    /Users/<YOUR USER NAME HERE>/Library/Application Support/Google/Chrome/Profile 1


So this number at the end is what I swap out when switching between profiles.

Simple, quick hustle :)


This by no means a production ready workflow, but for those who couldn't even try out the current workflow due to the error above and need some solutions.


This what it looks like for me in the end







Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...