Jump to content

Cntrl+ArrowKey L/R bindings don't work in Remote (started with Mojave Workspaces)


Recommended Posts

Okay, bear with me: I have a stupid simple keybinding + Alfred Remote buttons that I've set up in macOS that's worked forever in macOS up until Mojave. Let's set it up:

1 Open PrefPanes > Keyboard > Shortcuts Tab > Mission Control

2 Set "Move Left a Space' to cntl-LeftArrow, and "Move Right a Space" to cntl-RIghtArrow


Confirm that you can now do this with your keyboard. Still with me?

3 Go to Alfred Remote make a new remote

4 Make a keybinding button "Cntl-LeftArrow"

5 Make another one, "Cntl-RightArrow"

On any other OS previous to Mojave these remote buttons work, and I'm able to use Alfred to pass cntl-arrows to the OS. What happened?

Screenshots: 1 setting up Mission Control Keybindings 2 My "media remote" where all keys work EXCEPT the Control-Arrow keys.


Notes: Alfred current beta, Alfred has Accessibility and Automation Access granted ("System Events" and 2 other apps), Alfred Remote Server has Accessibility access.


Note2: I also use multiple keyboards, I verified that Alfred has accessibility permissions and also tried just using US keyboard, the remote does not work to move spaces left or right. The other keybindings I use in my "media remote" seem to work fine.


Does Alfred need Mojave "Notarization" before deeper scripts work?


Screen Shot 2018-12-17 at 15.57.39.png

Screen Shot 2018-12-17 at 15.57.14.png

Edited by leoofborg
minor edit
Link to comment
Share on other sites

It looks like your combos don't actually have a ^ on them (it should show in grey under this). This has actually made me spot a little visualisation bug which is preventing the icon updating. To set a combo which is already reserved in macOS, you should be able to press the main part of the combo (i.e. left arrow), then right click within the key combo field and select ^ to apply that. Currently, the right click selections don't seem to update the combo's icon.


Having said that, it does look like macOS isn't recognising these dispatched key combos as expected. This doesn't have anything to do with Notarisation - I'll take a look to see if there is anything I can do to work around this issue in Mojave!




Link to comment
Share on other sites

So it looks like this is a bug in Mojave, specifically relating to simulating hotkeys with the modified arrow keys. If you change the system shortcuts to something else, then this will work as expected.


I'll fix the visual bug of the key not updating in a future release :)


Screenshot 2018-12-18 at 14.20.19.png

Link to comment
Share on other sites

I found a "workaround" for Apple's stupid Mojave bug. You guys are going to LOVE this:


Made a couple Applescripts with code like this, 

on run
	tell application "System Events"
		key code 123 using {control down}
	end tell
end run

...ran into the "error 1002, keystrokes not permitted" bug/dumb feature, so...Had to make unique scripts, exported to apps in Script debugger, no save-as fun allowed.


Dragged each into Security & Privacy > Accessibility, went thru dialogs that added the unique apps into Automation > System Events... (see image)


Then dragged these applets into Alfred's remote. Gee thanks Apple.


Did I mention I *hate* giving up years of muscle memory? Anyway hope this helps someone.

Screen Shot 2018-12-19 at 17.30.52 2.png

Screen Shot 2018-12-19 at 17.55.58.png

Screen Shot 2018-12-19 at 17.56.29.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...