Jump to content
edbro

Preferences won't save - Didn't migrate from 3

Recommended Posts

Posted (edited)

I upgraded from ver 3 to 4 but not all my preferences migrated, even though I have iCloud syncing setup in Advance Pref. My workflows and snippets migrated but other prefs such as web searches, default activation key, etc, did not. I can't even save the option to save clipboard text.  I have granted all permissions and I've rebooted. When I look at my preferences backup file I see the file modification date is 5/10, despite trying to make changes today.
 

To make matters worse, when I manually make preference changes, they are not sticking. I've lost all my custom searches. I rely heavily on custom searches so I'd like to get them back ASAP.

Edited by edbro
grammar

Share this post


Link to post
Share on other sites

@edbro could you provide a bit more info about how you did the migration?

 

1. Did you do the backup before migration?

 

2. Did you select Copy or Sync for settings?

 

3. If you're using iCloud, do you have Optimised Storage disabled for iCloud Drive: https://www.alfredapp.com/help/advanced/sync/#services

 

4. Could you see if this folder was created within your home folder: ~/Library/Application Support/Alfred/ 

 

Thanks,

Andrew

Share this post


Link to post
Share on other sites

I have Alfred set to have preferences sync to iCloud, so I thought they were always backed up.

Alfred asked me if I wanted to migrate during the first run of ver 4. I said yes.

Optimize iCloud storage is disabled

There is no preferences folder in ~/Library/Application Support/Alfred/ 

 

I've given up on recovering my old preferences, I just want to be able to save new ones when I recreate them.

Share this post


Link to post
Share on other sites

Okay, I now see the warning about using iCloud for syncing preferences. I set my new location to my OneDrive folder and I can now save preferences. I think I'm all set now.

Share this post


Link to post
Share on other sites

×
×
  • Create New...