Jump to content

Files search results not showing correct path for external volumes


LudoMC
 Share

Recommended Posts

When searching for files (with ') that are on external volumes (my NAS primarily), the files are found, file icon is correct but the path is not the correct one and is completely unrelated (but is another path of the external volume). If I hit enter, it's the file shown on the path that is open, not the one I expect.

Spotlight finds the files correctly with the right path as it can open it.

 

There is no issue when files are on my laptop's internal hard-drive.

I just updated to Alfred 4 but had same issue on Alfred 3.

I did a "Clear application cache" in case, but no changes.

 

I'm on High Sierra 10.13.6 on a early 2011 MBP.

Screen Shot 2019-06-02 at 11.17.28.png

Link to comment
Share on other sites

@LudoMC This is a bit odd, and not something which has been reported before. Alfred receives the path to display from macOS's metadata and resolves / standardises it using a macOS API, so it's odd to be showing the incorrect thing.

 

1. Do you have any unusual symlinking between local and remote volumes, which Alfred could be finding?

2. Have you tried setting up a specific custom file search workflow to search ONLY within e.g. the SteamGames folder to see if the path is correct?

3. Have you tried reindexing the macOS metadata to see if this flushes through?

 

Cheers,

Andrew

Link to comment
Share on other sites

Hi,

 

no special symlink between volumes.

I tried defining a workflow to search for the full external volume. Still same issue.

Looking for a file that is in the SteamGames folder returns a result but with wrong path again (see attached picture). When restricting the search only to SteamGames folder, the file is not found!

I'll re-index, try again and let you know.

Thanks for your help

Screen Shot 2019-06-03 at 11.49.01.png

Edited by LudoMC
clarification
Link to comment
Share on other sites

Hi,

 

changing the filter deeper didn't change anything. It still gave the wrong path.

I then re-indexed the drives via the application (Advanced | Rebuild macOS Metadata). No changes. 

I then did it via Terminal with a

sudo mdutil -E {drive}

on all my indexed drives, and it then works correctly now.

I didn't check the difference between the script launched by the application and the command I used, most important thing being it works! :)

 

Thanks for your help (and your wonderful (and vital) application!)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...