Jump to content

Will Snippets work in RDP?

Recommended Posts

@PizzaGuyRidesAtDawn Welcome to the forum!


Are you logging in remotely into a macOS or Windows machine? There are quite a few factors to take into account, so given you're already a Powerpack user, have you simply tried to see if snippets work in your Remote Desktop scenario?


If you can provide more details about your particular setup, what has and hasn't worked so far, it'll be a lot easier for us to help you out :)





Link to comment

@PizzaGuyRidesAtDawn There are a few ways to work with the fact that you're using Windows. You're correcting that pasting assumes Cmd + V will paste the current pasteboard content.


The simplest way to deal with this is to pop up Alfred's Snippets Viewer, choose your snippet and use Cmd + C to copy it to your clipboard, then Ctrl + V to paste to your VM. 


I'm not familiar with Remote Desktop, but here are some steps I gave to a Parallels user some time ago, much of which would apply here:




1. Set your VM to use Cmd + V to paste clipboard contents. Alfred relies on this to paste the snippet content after removing the keyword.
2. In Alfred's Appearance > Options (bottom left of the sidebar), choose Focusing: Compatibility Mode.
3. In Features > Snippets > Auto Expansion Options > Tweaking, set the simulated key event speed to be at the slowest.


This should allow the snippets to work even in your Windows VM. Once you've got this working, you can try speeding up key events again, and possibly returning the focusing to Standard Mode.



However, this comes with the caveat that I do not have access to Remote Desktop to test it, so you'll likely need to fiddle around a little with your VM.


If all else fails, copying from the Snippet/Clipboard Viewer option will be your best option.


Let me know how you get on.



Link to comment
  • 9 months later...
  • 2 years later...

Sorry for resurrecting this ancient thread, but I am running into an issue with Alfred snippets simply showing "v" in a Citrix Viewer remote desktop. I have checked the keyboard settings in Citrix and they are correct (using command for control key) and command+v operates properly to paste text in Notepad. However, when I type a snippet, e.g. "gm" for 'Good morning' I get the snippet sound and my "gm" is replaced by 'v'. 


I do not see where to set the behavior to type instead of paste. I have my appearance set to compatibility mode. Not sure what else to do. Any thoughts?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...