Jump to content

[Solved] Alfred does no longer find folder names that end with .com/.org TLD


Recommended Posts

Posted (edited)

Hi there,

 

I do have a bunch of folder names that end with a top-level domain. Using Simple Folder Search does not longer work in Big Sur.. When I create a new folder called crazyproject.com Alfred is able to find them, though. I have rebuild the MacOS metadata index a couple of times. Spotlight lists folder that end with a dot as Web Internet location. Do I have expand Alfreds File Filter Input metadata? Alfred built-in File Search Troubleshooting does not show any errors  

 

What can I do?

 

Thanks

 

Screenshot 2022-05-29 at 23.42.36.png

 

Screenshot 2022-05-29 at 23.42.44.png

Edited by howdytom
Link to comment
  • howdytom changed the title to Alfred does no longer find folder names that end with .com/.org TLD
Posted (edited)

@Vero Thank you. I have checked multiple folders.

 

 

image.png.abd1c39fb79e5d409fae2127b885f6be.png

 

Starting Diagnostics...

File: 'mywebproject.com'
Path: '/Volumes/RAID/Sites'

-----------------------------------------------------------

Check file cache database...

 File cache integrity is ok

-----------------------------------------------------------

Check if file is readable...

 Alfred has permissions to read this file.

-----------------------------------------------------------

Check if volume '/Volumes/RAID/' is indexed by macOS...

 Indexing is enabled on this drive

-----------------------------------------------------------

Check direct file metadata...

 Direct metadata available

Display Name: mywebproject.com
 Other Names: 
Content Type: com.apple.web-internet-location
   Last Used: 

-----------------------------------------------------------

Check mdls file metadata...

 Metadata contains required items

_kMDItemDisplayNameWithExtensions      = "mywebproject.com"
kMDItemContentCreationDate             = 2009-05-22 14:29:36 +0000
kMDItemContentCreationDate_Ranking     = 2009-05-22 00:00:00 +0000
kMDItemContentModificationDate         = 2022-05-08 16:06:50 +0000
kMDItemContentModificationDate_Ranking = 2022-05-08 00:00:00 +0000
kMDItemContentType                     = "com.apple.web-internet-location"
kMDItemContentTypeTree                 = (
    "com.apple.web-internet-location",
    "com.apple.internet-location",
    "public.stored-url",
    "public.data",
    "public.item"
)
kMDItemDateAdded                       = 2022-05-08 09:58:00 +0000
kMDItemDateAdded_Ranking               = 2022-05-08 00:00:00 +0000
kMDItemDisplayName                     = "mywebproject.com"
kMDItemDocumentIdentifier              = 0
kMDItemFSContentChangeDate             = 2022-05-08 16:06:50 +0000
kMDItemFSCreationDate                  = 2009-05-22 14:29:36 +0000
kMDItemFSCreatorCode                   = ""
kMDItemFSFinderFlags                   = 0
kMDItemFSHasCustomIcon                 = (null)
kMDItemFSInvisible                     = 0
kMDItemFSIsExtensionHidden             = 0
kMDItemFSIsStationery                  = (null)
kMDItemFSLabel                         = 0
kMDItemFSName                          = "mywebproject.com"
kMDItemFSNodeCount                     = 7
kMDItemFSOwnerGroupID                  = 20
kMDItemFSOwnerUserID                   = 501
kMDItemFSSize                          = (null)
kMDItemFSTypeCode                      = ""
kMDItemInterestingDate_Ranking         = 2022-05-08 00:00:00 +0000
kMDItemKind                            = "web internet location"

-----------------------------------------------------------

Check file is in search scope...

 File exists within Alfred's default search scope

-----------------------------------------------------------

 Troubleshooting passed

 

image.png

Edited by howdytom
Link to comment

@howdytom If you take a look at the metadata, the content type is "com.apple.web-internet-location", not a folder - so a workflow set to search only for folders won't file that content type.

 

Is it a cloud-based drive? If so, what service are you using? 

Link to comment
Posted (edited)

These are local folders that are stored on a hard drive. Due to the fact that those folder end with a domain name e.g. .com, /.org / .de macOS somehow recognises them as com.apple.web-internet-location Content Type. Is there any workaround?

Edited by howdytom
Link to comment

@howdytom That's a macOS question rather than an Alfred question to be honest. I do believe there's a way to override the icon globally, but I can't remember off the top of my head, so a bit of online investigation may be required.

 

For anyone who comes across this thread in the future; The first step to investigate this is to look at the metadata, which will almost always give you the information you need to work out whether the file you're looking for is 1. of the file type you expect, 2. in the location you expect, 3. correctly indexed. :)

Link to comment
Posted (edited)

@Vero I really appreciate your great support. It is working like a charm, now! :)

 

Anyways, I have noticed the icon changes once I lookup those folders a couple of times. :D

Edited by howdytom
Link to comment
  • howdytom changed the title to [Solved] Alfred does no longer find folder names that end with .com/.org TLD

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...