Jump to content

Typing letter 'e' in search bar causes short freezing

Recommended Posts

When I type an 'e' in the search box, it causes Alfred to freeze 1-2 seconds.


After a few tests, I found out:

  • It only occurs when the letter 'e' is typed at the very beginning of a search string, no matter if there's more text behind this 'e'.
  • It occurs not only right after the search bar appears.
  • After each time the lag appears, the 'e' stops causing any lagging for about half a minute, before it occurs again (feels like cache?).
  • No error is shown in the workflow debug console.
  • No other key stroke causes the same problem.
  • It doesn't appear in any other app.


What I've tried to rule out:

  • Quit other apps which do keyboard mapping
  • Disable all workflow keywords starting with an 'e'
  • Clear application cache & rebuild macOS metadata
  • Restart Alfred


None of these worked. :(

When searching a single 'e', all I got in results were only just applications and web searches, altogether less than 10.

This is really bizarre and I have no idea...

Link to comment

@saor47 I've seen a few cases of this over the past 6 months (after years of no problems). As part of the performance and efficiency improvements in the future 5.1 release, I've already preempted this as an issue and moved discovering the ejectable drives off of the main thread.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...