Jump to content

Sonomoa update causing Alfred issues (finding apps)

Recommended Posts

@schmu I merged your other thread ("unknown indexing state" after Migration Assistant?) with this one as your posts were a continuation of this thread. Please continue the discussion here to make it easier to keep track of what's been discussed :) 

Link to comment
  • 2 weeks later...
  • 4 months later...

I have bad news. Another migration assistant casualty.


Just got new M3 MBP. Alfred was working fine, and is still working fine, on my older M2 MBP. Both running Sonoma 14.4.

Alfred finds folders down to a certain level: [Root]>[User]>[Dropbox]>[DB Folder One]. But stops there. It will not find subfolders in [DB Folder one.]


I found another topic that went through all of this exhaustively on Monterey, and I did all of the troubleshooting steps that people tried there. Including the following:

1.  Created test user. Spotlight found the subfolders there. Alfred did not. 
2.  Tried Spotlight on normal user profile. Spotlight finds subfolders, Alfred does not.
3.  Reindexed Spotlight.  It worked for about 20 minutes and then reverted to the same behavior. Subfolders that it found 20 minutes ago are now not found. Though are still found by Spotlight.

Before I went through the above, Houdahspot was not finding the subfolders. It worked after reindexing, and now appears to be holding steady. HS and Spotlight are still finding the subfolders, but Alfred is not.  

And it gets progressively worse. The subfolders that it cannot find are names of clients. For a while it did find the contacts cards of the clients, though not the folders. In the time it has taken me to write and edit this post, it has lost track of the contacts cards as well. 

Ppl talking about a manual install. Of what or which? Sonoma? The documents folders? Alfred? Everything? As in wipe the drive and start over? 


Edited by david96161
Link to comment
4 hours ago, david96161 said:

I found another topic that went through all of this exhaustively on Monterey

But did you follow all of the steps outlined on the Alfred help page linked earlier in the thread? If not, please do that—following each suggested step carefully (even though you may have done some already).


If you still have problems run one of the files which Alfred cannot find through Alfred's inbuilt troubleshooter (as indicated on the help page) and post the results here.


As you've mentioned Dropbox it will be worth checking you've ensured Dropbox files are made available offline.



Link to comment

I will check the other steps as you suggest.

As for Dropbox being available offline, please note my point that the behavior is sporadic. It wasn’t finding the files, and then it was, then it wasn't. (N.B. Now, the next morning, all Dropbox-located folders are appearing again.) At no time in that sequence did the online/offline status of a single Dropbox file or folder change. Also note that Spotlight is finding everything consistently. HoudahSpot was, then it wasn't, then it was. It ain't Dropbox.

The loss of the Contacts cards from search corroborates this. Contacts are on the root drive, not Dropbox. If it were a Dropbox online/offline issue, the Contacts cards would not have disappeared from search results.


I don't believe it's even related [much] to Alfred. It seems to be a Spotlight indexing issue. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...