Jump to content

Newbie Question: action not staying in app

Recommended Posts

Forgive me the maybe silly Newbie-question. When I run a workflow that just has to open a file in Obsidian, it works great, but it always leaves me with the finder upfront, instead of Obsidian. What am I doing wrong?

Thx for the help.


Link to comment

@Rudy Welcome to the forum :)


When asking a question about a workflow, the best thing to do is to look for the existing official thread for the workflow, which in this case might be this:



If you're referring to a different workflow, please link to the original source or share it if it's your own workflow.


Next, please include any additional information you can, such as your version of Alfred, macOS and relevant apps like Obsidian, as it's otherwise tricky for us to know what combination you're using.


And finally, please take a look at the debugger in case it can provide any additional relevant information:


Link to comment

Welcome to the forum.


When asking questions like this it's helpful to specify the name of the workflow you're using (or to upload a copy of it somewhere if it's your own workflow) so that someone can see whether there is a problem in the workflow itself—or, perhaps, in your own configuration of the workflow.


Edit: Sorry, replied at the same time as Vero's much more thorough answer!



Edited by Stephen_C
Link to comment

It was a first 'workflow' I made myself, with only 2 actions:  Ask a Keyword, followed by the action Open file, in Obsidian.  Works fine, but as I said, for some reason it does not stay IN Obsidian, but shows the Finder, although all windows of the Finder are closed. 


Link to comment

Does your Open File action have Obsidian shown in the righthand pane as the default for opening the file?


Edit: Please also do as requested at the end of Vero's post, run the debugger and copy and post the full output here.



Edited by Stephen_C
Link to comment

** Does your Open File action have Obsidian shown in the righthand pane as the default for opening the file?

Yes it does.


I think I loved it. Apparantly Alfred showed another Action, although it was not triggered by the key I gave it. I just cleaned out everything, and I think it works now. 

Sorry for the trouble. 




Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...