Jump to content

Recommended Posts

Assuming you are talking about workflows from the Alfred Gallery just do this:

  • Go to Alfred Preferences → Workflows.
  • At the bottom of the second column click on Alfred Gallery and then Check for Workflow Updates.
  • You can sort the list of workflows by Gallery updates to show the updates at the top (click on the button to the right of Filter at the top of the list) and then right click on each workflow needing an update and choose Update from Alfred Gallery.

Do note that if you make changes to a workflow from the Gallery the workflow will think it needs to be updated. If you need to make changes and avoid the workflow being overwrtitten you need to change the workflow's bundle identifier.


If that doesn't solve the issue for you please post with more detail about exactly what happens when you try to update a workflow (e.g., does it in fact update but the icon remain, or does it fail to update at all?) and confirm your Alfred and macOS version numbers.



Link to comment

Hello Stephen, thank you for responding to my post so quickly.


Sadly, that is what I have been doing, but I haven't had any luck. When I try updating the workflow using the method you mentioned, it disappears from my list for about 10 minutes and then shows up again, still requesting an update. 



I tried deleting the old version and redownloading the newly updated workflow from the Gallery, but now I can't even delete the old workflow. When I try going into the alfredpreferences.app in my folders to delete it manually, I get the error message attached.


Link to comment

Please confirm your macOS and Alfred version numbers.


When you choose "Update from Alfred Gallery” what exactly happens? Do you see anything happen on screen or any error message?


Where do you store your Alfred preferences? Are they stored in the default location or in some location you have set in order to sync them?


Edit: Are you using a VPN?



Edited by Stephen_C
Link to comment
  • 2 weeks later...

I'm experiencing the same problem: Workflows appear as upgradeable, but after updating via the "Workflow Gallery" nothing changes. The update symbol remains in place, but the workflow shows no content when clicked on in the list view. After closing the preferences window, it is as before (listed as upgradeable).


I'm using Alfred 5.5 on two MacBooks. The file "Alfred.alfredpreferences" lies on my iCloud-drive and is used by Alfred on both MacBooks. The path in the preferences window is set correctly. I do not use a VPN.


Is there any solution for this issue?

Link to comment

Thank you for your reply.


After moving the preferences to the local disk, I was able to update the workflows. This lets me assume that the problem is connected with iCloud.


Addendum: I turned off Optimized Storage. I'm on macOS 14.4.

Link to comment

This also worked for me! Thank you everyone, for all of your help.


Another quick tip on Mac: If you don't want to completely disable optimized storage, add ".nosync" to the end of the file name that you want to remove from iCloud syncing. (Screenshot of how the unsynced file should look on your desktop)

Screenshot 2024-03-23 at 5.07.53 AM.png

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...