Jump to content

I can't use chatgpt workflow behind proxy

Recommended Posts

I upgraded to Legendary license this morning for using chatgpt workflow.  However, it doesn't work (refer to attached screenshot.png).  I need to use a proxy to go to chatgpt website, so can this workflow support proxy? 


Link to comment

@Zhibin He Thanks for buying a Legendary! :)


To expand on this, you can configure Alfred to use your macOS configured proxy for all Workflows in the Alfred's Advanced preferences by ticking the "Use macOS http proxy settings for scripts" option.

If it's just a single workflow you'd like to configure to use a proxy, adding the https_proxy variable to the workflow environment variables (Use the link @vitor provided) will be passed to the script which is connecting to ChatGPT's API.


Alternatively, if you're using a VPN, Alfred would also work with this by default without the need to use proxy settings.




Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...