Jump to content

"AppName" Return no longer opens the app


Piers Cawley
 Share

Recommended Posts

Version: Alfred 2.1.1 (227) on Mavericks 10.9 (13A603)

 

I hit the trigger key and type, say "Textual" and hit Return. Instead of launching/focussing Textual, I'm prompted for a document to open. In the case of Textual, there are no documents available, but when I hit enter again, instead of opening Textual, nothing happens.

 

If I do something similar with pages, where I have some recently viewed documents, then I can select one and hitting Return will happily open the app.

 

After some experimentation and swearing, I worked out that, if I want the old behaviour, I can do <trigger> "Textual" <shift-Return>, but that's not really an adequate solution, especially as that's not how Alfred is documented as working.

 

If this is supposed to be the new Right Way, then fine, but please supply a preference setting for old stick in the muds like me who want the old behaviour.

Link to comment
Share on other sites

Version: Alfred 2.1.1 (227) on Mavericks 10.9 (13A603)

 

I hit the trigger key and type, say "Textual" and hit Return. Instead of launching/focussing Textual, I'm prompted for a document to open. In the case of Textual, there are no documents available, but when I hit enter again, instead of opening Textual, nothing happens.

 

If I do something similar with pages, where I have some recently viewed documents, then I can select one and hitting Return will happily open the app.

 

After some experimentation and swearing, I worked out that, if I want the old behaviour, I can do <trigger> "Textual" <shift-Return>, but that's not really an adequate solution, especially as that's not how Alfred is documented as working.

 

If this is supposed to be the new Right Way, then fine, but please supply a preference setting for old stick in the muds like me who want the old behaviour.

 

It sounds like you have some keyboard mapping going on somewhere (maybe a 3rd party keyboard remap tool?) which is causing e.g. ctrl to trigger, showing the actions panel, then recent documents.

 

You can either turn off any custom keyboard remapping, or if you open Alfred's preferences to Features > File Search > Actions and un-tick e.g. ctrl, then this issue should go away.

 

Cheers,

Andrew

 

Related topic: http://www.alfredforum.com/topic/3402-keys-remapped-via-keyremap4macbook-doesnt-work/

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...