Jump to content

Can't add workflows


jhopper28
 Share

Recommended Posts

When attempting to add a new workflow from a template or import from a downloaded shared workflow, nothing appears in the Alfred workflow window. I used to have a couple of my own that also no longer appear. My workflows are empty, and I can't add any more no matter what I do.

Link to comment
Share on other sites

When attempting to add a new workflow from a template or import from a downloaded shared workflow, nothing appears in the Alfred workflow window. I used to have a couple of my own that also no longer appear. My workflows are empty, and I can't add any more no matter what I do.

 

Hi there,

 

When you double-click a workflow to import it, do your Alfred preferences pop up to the Workflows tab and a dropdown menu appears giving you a summary of the workflow you're about to import, with an "import" button? 

 

For example, try importing this simple PDF file search workflow I've created:

https://dl.dropboxusercontent.com/u/5818788/Alfred/PDF%20File%20Searcher.alfredworkflow

 

Are you syncing your preferences? If so, where are you syncing them? Could you please set the sync folder to your Desktop, then try saving workflows again and let me know if that works?

 

Cheers,

Vero

Link to comment
Share on other sites

Yes, when I import your PDF workflow, it does open up in Alfred's workflow tab and allow me to import the workflow. However, upon restarting Alfred, the workflow is gone.

 

And yes, I'm syncing to a folder on iCloud Drive. But when I try repointing to my desktop or any other folder, I get the error message:

 

Unable to setup preferences path

Reason: The file “Alfred.alfredpreferences” couldn’t be opened because there is no such file.

 

So I seem to be unable to re-set the sync folder. I think your diagnosis here and in my other post are correct, though. I didn't see the relation at first, but now that I think about it, nothing that attempts to save preferences succeeds any more. For example, I also can seem to get any changes to the Remote pages to stick, either.

Edited by jhopper28
Link to comment
Share on other sites

Yes, when I import your PDF workflow, it does open up in Alfred's workflow tab and allow me to import the workflow. However, upon restarting Alfred, the workflow is gone.

 

Ok, it looks like your preferences aren't saving correctly; It's likely that your permissions have become corrupted, causing Alfred to be unable to save your preferences changes.

 

First, quit Alfred. Then launch Disk Utility and click "Repair Permissions". Once you've done this, back up your Alfred.alfredpreferences file from your sync folder (if you want) and reset Alfred's settings to defaults by deleting the folders listed here:

http://support.alfredapp.com/kb:reset-alfred

 

When you restart Alfred, he'll create a new preferences file in the default location and it should save correctly once again :)

 

Let me know how you get on!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...