Jump to content
stuartcryan

LastPass Workflow for Alfred - update v1.4.7 August 19, 2016

Recommended Posts

If it's supposed to bypass 2FA, then it works. I was able to login using just my master PW.

Howdy

Apologies, I should have specified, you will need to load up the web interface, click on account settings, go to trusted devices and remove the trusted device (which should be your computer name) it will then re-prompt for 2FA.

Cheers,
Stuart

Share this post


Link to post

All righty, with a huge thanks to Ariel, we have a new version:

Version 1.4.4

  1. Merged in code submitted by Ariel Barreiro to better support two factor authentication (2FA).

So those of you that have been having issues, should be able to log in without any issues now. As always please let me know if you have any issues.

Cheers,
Stuart
 

Share this post


Link to post

Perfect. I did as you suggested, works flawlessly.

 

If you don't mind, I'd like to suggest some features for future releases. The primary functionality is getting passwords and usernames out very quickly, and it's near flawless at this point. However, there are things that I think of when I'm in the middle of doing something that would be incredibly helpful.

Share this post


Link to post

Perfect. I did as you suggested, works flawlessly.

 

If you don't mind, I'd like to suggest some features for future releases. The primary functionality is getting passwords and usernames out very quickly, and it's near flawless at this point. However, there are things that I think of when I'm in the middle of doing something that would be incredibly helpful.

Of course please fire away.

 

Best place is on https://github.com/stuartcryan/lastpass-alfred-workflow/issueswhere there are already a couple. One big one that is often requested is to have the website launch and auto login, however that would require essentially writing a plugin for each browser to take the input and translate it into a login (and this is already achievable with one of my other workflows for loading up tabs and then just using Lastpass natively auto logging in in the browser).

 

:) Definitely looking forward to your ideas (and anything that could take us from near flawless to flawless) :D

Share this post


Link to post

Of course please fire away.

 

Best place is on https://github.com/stuartcryan/lastpass-alfred-workflow/issueswhere there are already a couple. One big one that is often requested is to have the website launch and auto login, however that would require essentially writing a plugin for each browser to take the input and translate it into a login (and this is already achievable with one of my other workflows for loading up tabs and then just using Lastpass natively auto logging in in the browser).

 

:) Definitely looking forward to your ideas (and anything that could take us from near flawless to flawless) :D

 

 

While I see what you're getting at, I think the request is simpler than that. We can just install the LP plugin in whatever browser we want to use and it'll take care of the auto login. What I would like to see is more of a "quick launch" from the workflow. For example, if I need to launch a site from a specialized hyperlink, it'd be a simple matter of press a modifier key, "Launch Site" appears, hit enter and let the default browser plugin take care of the rest.

 

The reason why it would be useful in my case is because I don't have bookmarks for every client's admin portals. That would be way too much overhead. Plus, I don't normally manage a lot of other clients, but when I'm asked to, I want to rely on my other team members to have entered the URL correctly so when I (in theory) use the workflow, all I have to do is press the modifier key, it pulls the url and executes in whatever default browser and the official LP plugin takes over.

 

Maybe other requests were trying to do more than that, but that's how I thought of it.

 

Anyhow, I'll submit a couple other ideas at the git page you linked. Thanks again!

Edited by mburchett2

Share this post


Link to post

While I see what you're getting at, I think the request is simpler than that. We can just install the LP plugin in whatever browser we want to use and it'll take care of the auto login. What I would like to see is more of a "quick launch" from the workflow. For example, if I need to launch a site from a specialized hyperlink, it'd be a simple matter of press a modifier key, "Launch Site" appears, hit enter and let the default browser plugin take care of the rest.

 

The reason why it would be useful in my case is because I don't have bookmarks for every client's admin portals. That would be way too much overhead. Plus, I don't normally manage a lot of other clients, but when I'm asked to, I want to rely on my other team members to have entered the URL correctly so when I (in theory) use the workflow, all I have to do is press the modifier key, it pulls the url and executes in whatever default browser and the official LP plugin takes over.

 

Maybe other requests were trying to do more than that, but that's how I thought of it.

 

Anyhow, I'll submit a couple other ideas at the git page you linked. Thanks again!

 

Now THAT seems like a completely fair use case (first time someone has presented it well enough that it made sense to do)! That I can definitely and happily do (and makes perfect sense). That should be relatively easy to do in the next release :)

 

Look forward to seeing your other suggestions too.

 

Cheers,
Stuart

Share this post


Link to post

 

Now THAT seems like a completely fair use case (first time someone has presented it well enough that it made sense to do)! That I can definitely and happily do (and makes perfect sense). That should be relatively easy to do in the next release :)

 

Look forward to seeing your other suggestions too.

 

Cheers,
Stuart

 

 

 

Yayyy!! Glad I could get that cleared up. :)

Share this post


Link to post

Ladies and gentlemen, v1.4.5 has now been released.

 

With this version comes the following:

  1. Fixed detection for when login has timed out, now correctly requests login.
  2. Fixed rare cases of login-script loops.
  3. Improved speed of copying usernames.
  4. Updated documentation.
As always you can download from Packal, download the latest .alfredworkflow file directly or visit the official github repository (where you can log any issues, feedback or suggestions also).
Cheers,
Stuart

Share this post


Link to post

 

Ladies and gentlemen, v1.4.5 has now been released.

 

With this version comes the following:

  1. Fixed detection for when login has timed out, now correctly requests login.
  2. Fixed rare cases of login-script loops.
  3. Improved speed of copying usernames.
  4. Updated documentation.
As always you can download from Packal, download the latest .alfredworkflow file directly or visit the official github repository (where you can log any issues, feedback or suggestions also).
Cheers,
Stuart

 

 

 

Username copying much improved. Thanks again!

Share this post


Link to post

Username copying much improved. Thanks again!

No worries :)

 

It is good now that things are becoming more stable after being tested in so many different environments. Hope to start looking at new features soon.

Cheers,

Stuart

Share this post


Link to post

No worries :)

 

It is good now that things are becoming more stable after being tested in so many different environments. Hope to start looking at new features soon.

Cheers,

Stuart

 

 

Ah yeah, I forgot to add a few feature requests. Some of them are pipe dreams, but maybe they'll trigger some creative thinking on your part. I'll add to the github site.

Share this post


Link to post

Ah yeah, I forgot to add a few feature requests. Some of them are pipe dreams, but maybe they'll trigger some creative thinking on your part. I'll add to the github site.

*JAWDROPS* mwahaha those are some solid feature requests!

 

Not to worry, I will *see* what I can do but some of them may need some more community involvement/dev help.

Cheers,
Stuart

Share this post


Link to post

 

*JAWDROPS* mwahaha those are some solid feature requests!

 

Not to worry, I will *see* what I can do but some of them may need some more community involvement/dev help.

Cheers,
Stuart

 

 

 

Absolutely. Like I said, pipedreams. As it stands, this workflow is a really cool way to access LP, but if there were ever a jumping off point to do some extremely cool things, this would be it.

 

As it stands, I'm very happy with where it's at. You are the best!

Share this post


Link to post

Just came across this and seemed to have installed everything correctly but nothing happens when I try to login. No pop up or anything. Alfred just goes away. I have properly set my email address login and got confirmation from the workflow.

 

I checked console log and saw this after trying to login. But that doesn't appear anymore when I keep trying to login so not sure if that was just random and not tied to this workflow. Any ideas how to debug?

 

2016-04-13 3:53:25.282 PM Safari[37397]: KeychainGetICDPStatus: keychain: -25300
2016-04-13 3:53:25.282 PM Safari[37397]: KeychainGetICDPStatus: status: off

Edited by LiamW

Share this post


Link to post

Just came across this and seemed to have installed everything correctly but nothing happens when I try to login. No pop up or anything. Alfred just goes away. I have properly set my email address login and got confirmation from the workflow.

 

I checked console log and saw this after trying to login. But that doesn't appear anymore when I keep trying to login so not sure if that was just random and not tied to this workflow. Any ideas how to debug?

 

2016-04-13 3:53:25.282 PM Safari[37397]: KeychainGetICDPStatus: keychain: -25300

2016-04-13 3:53:25.282 PM Safari[37397]: KeychainGetICDPStatus: status: off

 

 

I'm in the same boat, email address set, but nothing happens when I try to log in.

 

OS X 10.11.4, Alfred 3.

Share this post


Link to post

I'm in the same boat, email address set, but nothing happens when I try to log in.

 

OS X 10.11.4, Alfred 3.

I was having the same problem, but was able to fix it by editing the login script in the Workflow.

 

Open up the LastPass workflow in Alfred preferences.  Find the lplogin keyword (at the top of the workflow) and open the script to the right of it.  Scroll all the way down to the bottom, and you'll notice that on the second to last line, it tries to open Alfred 2.  Just change the 2 to a 3 and it will start working again.

Share this post


Link to post

Just came across this and seemed to have installed everything correctly but nothing happens when I try to login. No pop up or anything. Alfred just goes away. I have properly set my email address login and got confirmation from the workflow.

 

I checked console log and saw this after trying to login. But that doesn't appear anymore when I keep trying to login so not sure if that was just random and not tied to this workflow. Any ideas how to debug?

 

2016-04-13 3:53:25.282 PM Safari[37397]: KeychainGetICDPStatus: keychain: -25300

2016-04-13 3:53:25.282 PM Safari[37397]: KeychainGetICDPStatus: status: off

Howdy please give this beta version a try:

https://dl.dropboxusercontent.com/u/9093155/LastPass%20CLI_1.4.6_beta1.alfredworkflow

Share this post


Link to post

I just tried this version and the same thing happens. That is nothing when I try to login to LP through your alfred package. I can set my email address and get the notification that it set, but comes up blank when I try to login.

Share this post


Link to post

Hello to all.

I can't seam to make it work. When I set the email Lastpass login, next step never happen - I cannot input password, there is no terminal :(. Is there any solution to that? 

Please help me.

 

 

Thank you

I'm really looking forward to use this.

The Idea is Addictive

 

have a nice one,

Luka

Share this post


Link to post
Hi Everyone,

With my sincere apologies for the delay, the new version of the workflow is available and out of beta. My masters course at uni this semester has taken up my life for the last three months, hence the delay and not being able to move the fix from beta to the official branch.

 

Here are this versions changes:

 

Version 1.4.6


  1. Updated to work with Alfred 3 (long awaited official release of the long-in-testing beta version).



  2. Username display functionality submitted by Guillermo Moreno has been merged in with some minor changes (thanks for your hard work Guillermo!)



  3. Released with my apologies for the delay in getting this version out of beta... my masters course was INTENSE this semester, thank you to all of those that waited patiently.



Cheers,

Stuart

 

Share this post


Link to post

Trying this new version with Alfred 3. 

 

Might be a dumb question, but how does one login with this? I set my email, and if I hit lplogin and enter, in the Alfred debug window I get the following error:

 

2465:2767: execution error: Please enter the LastPass master password for <my email address>.

Master Password: Error: Failed to enter correct password. (1)

 

If I type lplogin and then spacebar to type my password, it just goes to a Google search.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...