Sign in to follow this  
Followers 0
FroZen_X

Autoexpand in Note App creates newline

10 posts in this topic

Hello,

 

while using OS X Notes app, autoexpand adds a newline to the expanded word. Only happens from the 2nd line on.

Look here:

 

d4oclFM.gif

 

This seems to happen only in Notes.

 

OS X 10.11.5

Alfred v3.0.1 Build 657

 

 

Cheers,

 

FroZen_X

Share this post


Link to post

Hello,

 

while using OS X Notes app, autoexpand adds a newline to the expanded word. Only happens from the 2nd line on.

Look here:

 

This seems to happen only in Notes.

 

OS X 10.11.5

Alfred v3.0.1 Build 657

 

 

Cheers,

 

FroZen_X

 

 

If you copy and paste that same check mark into Notes, do you get the same behaviour?

 

Cheers,

Andrew

Share this post


Link to post

If you copy and paste that same check mark into Notes, do you get the same behaviour?

 

Cheers,

Andrew

 

The same behaviour happens with anything i copy paste as i see now.

See here:

 

29DbQrC.gif

 

Is that a Notes bug? Or a settings problem?

Share this post


Link to post

The same behaviour happens with anything i copy paste as i see now.

See here:

 

Is that a Notes bug? Or a settings problem?

 

 

That looks like a Notes bug to me!

Share this post


Link to post

Damnit, i just checked out this thread: http://apple.stackexchange.com/questions/84823/how-to-force-os-x-notes-application-to-lose-formatting-when-i-paste-text-from-cl

 

When you paste with Opt+Shift+Cmd+V then it doesn't happen. This matches then the current style. Could Alfred do the same?

 

 

Not all apps support that combo, so it would turn things into a bit of a fudge which I'm not willing to do.

 

I'm moving this to noted as it's not a bug in Alfred, and I'll keep this in mind for the future.

Share this post


Link to post

Not all apps support that combo, so it would turn things into a bit of a fudge which I'm not willing to do.

 

I'm moving this to noted as it's not a bug in Alfred, and I'll keep this in mind for the future.

 

I understand and that's not what i meant or wanted you to do ^^

A keycombo is nothing reliable.

 

In the Forum they were talking about paste and match the style. Was thinking if that would be possible.

Like remove all previous formattting etc.

Share this post


Link to post

I understand and that's not what i meant or wanted you to do ^^

A keycombo is nothing reliable.

 

In the Forum they were talking about paste and match the style. Was thinking if that would be possible.

Like remove all previous formattting etc.

 

 

Alfred always pastes without formatting (plain text), so I suspect that within Notes.app itself, it internally treats the paste and match style key combo differently.

Share this post


Link to post

Alfred always pastes without formatting (plain text), so I suspect that within Notes.app itself, it internally treats the paste and match style key combo differently.

 

Andrew!

The thread itself provided the fix!

Like this:

If you would like to make this the default action when pressing ⌘V, open System Preferences -> Keyboard -> Keyboard Shortcuts, and select Application Shortcuts from the list on the left. Then, hit + to make a new shortcut, select Notes.app from the dropdown list, enter Paste and Match Style exactly in the Menu Title box, then hit ⌘V with your cursor in the Keyboard Shortcut box. After hitting Add, you can flip back to Notes.app and click on the Edit menu to see that the shortcut has been reassigned.

 

 

When i set the shortcut for Notes and set Menu Title to "Paste and Match Style", it fixes also Alfreds expand :)

Might be helpful for others.

Edited by FroZen_X

Share this post


Link to post
Sign in to follow this  
Followers 0