Jump to content
manan

Clipboard history pasting 3.1

Recommended Posts

v 3.1 Build 718

OSX 10.11.6 (15G31)

 

I tried to paste clipboard history from alfred to iterm2, but after select the clipboard history and input 'Enter', only a character 'v' was pasted on screen. And input 'Cmd+v' at this time, the clipboard history selected is pasted.

 

 

The clipboard history pasting works fine in other apps, but it won't work in iterm2 in v 3.1. 

 

Is this a bug or something wrong with my iterm2 settings?

 

 

ScreenShot:

http://imgur.com/a/lQiJq

Share this post


Link to post
Share on other sites

Have you configured iTerm to use ctrl instead of cmd when pasting?

 

Cheers,

Andrew

 

I remap the Left Option key to Left Command key, and remap Left Command key to Left Option key in iterm2. After canceling this remapping, the clipboard history pasting works fine again.

 

Before alfred v3.1, the history pasting works fine in iterm2 with the key remapping above.

 

Can I still use the clipboard history pasting without canceling remapping of Left Command key? Since this remapping is important to me. 

 

Thanks!

Share this post


Link to post
Share on other sites

I remap the Left Option key to Left Command key, and remap Left Command key to Left Option key in iterm2. After canceling this remapping, the clipboard history pasting works fine again.

 

Before alfred v3.1, the history pasting works fine in iterm2 with the key remapping above.

 

Can I still use the clipboard history pasting without canceling remapping of Left Command key? Since this remapping is important to me. 

 

Thanks!

 

 

The behaviour for this hasn't changed from v3 through to v3.1 so not sure what could have changed? Have you tried 3.0.3 again to see if the behaviour is as it was?

 

https://cachefly.alfredapp.com/Alfred_3.0.3_694.dmg

 

Cheers,

Andrew

Share this post


Link to post
Share on other sites

The behaviour for this hasn't changed from v3 through to v3.1 so not sure what could have changed? Have you tried 3.0.3 again to see if the behaviour is as it was?

 

https://cachefly.alfredapp.com/Alfred_3.0.3_694.dmg

 

Cheers,

Andrew

 

I tried v3.0.3 (using the Alfred_3.0.3_694.dmg you provide), and the behaviour is as it was: the pasting works fine. 

 

I didn't reset iterm2 during this testing, so I believe something is different between v3.0.3 and v3.1 on this issue.

Share this post


Link to post
Share on other sites

I tried v3.0.3 (using the Alfred_3.0.3_694.dmg you provide), and the behaviour is as it was: the pasting works fine. 

 

I didn't reset iterm2 during this testing, so I believe something is different between v3.0.3 and v3.1 on this issue.

 

 

Looking back at my 3.1 changes, there is one change which may have affected this, but has fixed more important behaviour coming in 10.12 which made mod keys stuck on simulating them. This leaves me in a tricky situation as Alfred 3.1 is essentially working correctly, and even works correctly if you switch the cmd & ctrl keys in OS X's Keyboard > Modifier Keys preferences.

 

I'll pop an email to George (iTerm2 creator) and see if he has any ideas.

 

Cheers,

Andrew

Share this post


Link to post
Share on other sites

×