Jump to content
doctorwho

Cannot search through `Google Chrome` bookmarks [Fixed 3.6 b893 pre-release]

Recommended Posts

Which version of macOS are you running?

 

Which version of Chrome are your running?

 

How many Chrome profiles do you have?

 

Are you trying to search the default profile?

Share this post


Link to post
Share on other sites

- macOS: High Sierra 10.13

- chrome version: Version 62.0.3202.62

- num of chrome profiles: two (`Work` and `Home`)

 - able to search through bookmarks in `Work` profile but not `Home`

- removed both profiles and added them again in order: `Home` and then `Work`

- even now, only able to search for bookmarks in `Work` profile

 

Note: Not sure how to check which is the default profile

 

 

Share this post


Link to post
Share on other sites
15 hours ago, doctorwho said:

able to search through bookmarks in `Work` profile but not `Home`

 

That's not quite the same as "cannot search through chrome bookmarks"…

 

AFAIK, Alfred doesn't support multiple profiles yet. It only reads the bookmarks in "Profile 1", which is presumably "Work".

 

EDIT: My bad. I think Alfred only reads bookmarks in "Default".

Edited by deanishe

Share this post


Link to post
Share on other sites

That's not quite the same as "cannot search through chrome bookmarks"…

~Got it, will update the title of the post.~  --Okay, not able to do this
Also, the searching through one profile occurred only after seeing your question about the number of profiles, so.

 

So, removed the `Work` profile and just having my `Home` profile on Chrome. Still not able to search through the bookmarks present in the `Home` profile (which is the only profile on Chrome now)

 

Feels more like a Chrome issue though. Is it?

Edited by doctorwho

Share this post


Link to post
Share on other sites

Used the info on that link to create a symlink for the bookmarks file I wanted.

Thanks a bunch!

 

Below is some info which might help in troubleshooting: 
- I deleted both my profiles (on 2017-10-22)
- Which deleted the profile folder `Default`
- And when i added both the profiles again (same date), two directories `Profile 2` and `Profile 4` was created in /Users/myusername/Library/Application Support/Google/Chrome

- Think that the current Chrome version is calling the folders not by my profile name but as `Profile 1`, `Profile 2`, (like a profile ID)

- But there is no `Default` folder

- And think Alfred is looking for the bookmarks in the folder `Default` 

Share this post


Link to post
Share on other sites
13 hours ago, doctorwho said:

And think Alfred is looking for the bookmarks in the folder `Default` 

 

I think that's still the case, yes. I was mistaken earlier when I said "Profile 1".

Edited by deanishe

Share this post


Link to post
Share on other sites

The Alfred 3.6 b893 pre-release is now aware of multiple Google Chrome profiles, and you can select which one you'd like to use in Alfred's Web Bookmarks features prefs.

 

If you have setup any symlinks workarounds etc, it's probably worth backing these changes out now.

 

Cheers,

Andrew

Share this post


Link to post
Share on other sites

×
×
  • Create New...