Jump to content
zombieswontgetme

[SOLVED] Is there a character limit where Alfred stops searching?

Recommended Posts

Hi all, first post, sorry if this is a common question (didn't see in search results)

 

I have a file called xxxxxxx-xxx-xxxx-xxxxxx-synthesis-1a-20180712, but typing "find synthesis" does not locate the file. Creating a duplicate in the same place with just the name "synthesis" works. Is this a setting I can change or a powerpack option? A bug? A feature?!

 

Thanks in advance.

 

Mac OS 10.12.6

Alfred v 3.6.1 [910]

Edited by zombieswontgetme

Share this post


Link to post
2 hours ago, zombieswontgetme said:

sorry if this is a common question

 

It isn’t. I can reproduce, so I’m moving to the bugs section.


Please edit the top post to include your Alfred and macOS versions, in accordance to this post.


Also, I forgot to test but, can Spotlight find the file?


Welcome to the forums.

Share this post


Link to post

@zombieswontgetme This is to do with word breaks / non anchored based searching.

 

After a change in the macOS metadata search server (about 4 years ago), hyphens are no longer treated as word breaks without overhead, and as Alfred uses word breaks in the default searches by design, the specific file search you are describing will no longer match in Alfred's default results.

 

You have a few options with this:

  1. Add a * to do wildcard matching, so show Alfred and use "open *synthesis".
  2. Use spaces instead of hyphens in your filenames.
  3. Replace Alfred's default searches with workflow file search objects configured to not do word based matching.

It's worth noting that Alfred uses highly refined word based queries, so while no.3 above will give you more results (perhaps more similar to Spotlight's results too), it will make the queries much more noisy and slower.

 

Cheers,

Andrew

 

[Moving to discussion and help]

Share this post


Link to post

Hi @Andrew,

 

I got sent from this thread to that one by @vitor.

 

Thanks for offering the three solutions above. However, option no. 2 is not necessarily a viable option, and as you document, option no. 3 has many drawbacks.

 

Would it be doable for Alfred to offer an option that would replace spaces with * when performing file searches? This would allow option no. 1 to become available without having to replace all spaces with asterisks in queries.

 

As an aside, I'll add that I find the macOS to discard dashes as word breaks incredibly constraining: the threads on this board are enough evidence to realise how disconnected it is from user cases where dashes are important to treat as such. I would therefore value a fix in more intelligent software, like Alfred.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...