Jump to content
mari

[SOLVED] find/open/in defaults to web search when I enter a search term

Recommended Posts

I'm on the latest version of Alfred, and I'm not sure when this stopped working, but at some point, open/find/in just stopped working, and goes back to a default web search.

 

If I type any of the commands, I get the correct behaviour at first:

opIQspA.png

However, once I start typing the name of a file, it defaults to searching the web:

3X6aCze.png

 

Quick File Search is enabled in the preferences, and all the commands are enabled as well:

iKzIs79.png

 

Does anyone know what I might need to fix?

 

Share this post


Link to post

@mari Alfred will switch to the fallback searches if there are no matching results found on your Mac, so it looks like out of the available files within your defined search scope, none match "ege".

 

Take a look at the Indexing Troubleshooting page here, as it walks you through the possible steps:

https://www.alfredapp.com/help/troubleshooting/indexing/

 

It may be that your Mac's metadata index would benefit from being rebuilt, if you expect to find a relevant file within your search scope (defined on the Default Results preferences tab) and it's not appearing. You can rebuild your index from Alfred's Advanced preferences.

 

If you're expecting to find a file, could you please let us know what file type, what the path is and provide a screenshot of your Default Results prefs?

 

Let us know how you get on :)

 

Cheers,
Vero

Share this post


Link to post

I do have a file with a file name including that that (the path being "/Users/Mari/Documents/egenmelding.txt"), and even if I just type "e" or any other single letter, which I obviously have a lot of files matching, it defaults back to a web search:

uU0Wx4T.png

 

These are my Default Results prefs. As I understand it, regardless of these settings, when I use "open" or "find" it should search my whole Home folder?

IRugzT5.png

 

I'll try to rebuild the index, because as far as I know, I haven't changed any of these settings in years, and it used to work fine. As it is now, no search terms at all work with open/find/in.

Share this post


Link to post
Posted (edited)

Welcome @mari,

 

Have you tried the troubleshooting steps? Have you disabled Spotlight, by any chance?

 

On a tangential note, I’ll ask that you avoid saying you’re on the “latest” version and always say the exact one. When you say “latest” we don’t know if you mean the latest pre-release or stable version, nor do we know if you’re actually on the newest version. You may think you’re up to date but be mistaken, or might be a version behind because the auto-update hasn’t kicked yet, or we may not be on what we think is the latest version but isn’t, or a multitude of other reasons. It also does not help someone who comes later with the same issue, as they’ll have no idea if their version matches yours.

 

Thank you.

Edited by vitor

Share this post


Link to post

I don't have Spotlight disabled, no. Re-indexing everything followed by a restart seems to have solved the problem, so thank you @Vero!

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...