Jump to content

[SOLVED] Deepl Workflow Problems

Recommended Posts

Hello, I've not been able to get this to work. First I get two of the same options and sometimes two of the same answer, but in any case, the result is always the same language, but w/o spaces. I've played w/ the target and initial languages (assuming I'm doing it right, there are two places to set these per the instructions), but the result is always in English. I want to convert English to German.


I'm using this workflow:




Here's the debug info:
[13:26:44.539] Deepl-Translate[Script Filter] Queuing argument 'this is a test.'
[13:26:44.556] Deepl-Translate[Script Filter] Queuing argument 'this is a test.'
[13:26:46.694] Deepl-Translate[Script Filter] Script with argv '(null)' finished
[13:26:46.698] ERROR: Deepl-Translate[Script Filter] Code 4: parse error: Invalid numeric literal at line 2, column 0
[13:26:46.699] Deepl-Translate[Script Filter] Script with argv '(null)' finished
[13:26:46.700] Deepl-Translate[Script Filter] {
  "items": [
      "uid": null,
      "arg": "thisisatest",
      "valid": "yes",
      "autocomplete": "autocomplete",
      "title": "thisisatest"



Link to comment

Hello @romebot,


When making a request or a bug report pertaining to a specific workflow, please do not open a new thread to discuss your issue.

Making a new thread, while it seems like it’ll give your problem visibility, will only fragment the discussion and make it less likely the author and users of the workflow (the people that can actually help) will see it.

Please read the Reporting Problems with Workflows topic, as it gives a nice overview on how to make a report with a better chance of being addressed.


You best bet here would be to contact the developer on Github, as they seem to be responsive.

Link to comment

thanks vitor, but i did consult vero before I posted. I was told that because this workflow didn't yet have a forum page, that it was ok to start a new thread (if it had one of course I would have posted there). So in what cases can one start a new thread? Are you saying that if there's no forum page, the go toGithub? or just in this particular case?

Link to comment

I was saying that in this particular case the Github route is a better bet. Precisely because there’s no forum thread, there’s no guarantee anyone on these forums uses that Workflow, so you’re banking on the eventuality that:

  • Users of that Workflow frequent the forum.
  • They will see this thread (whose visibility will decrease over time).
  • Will have the skills to help.
  • Will have the availability to help.
  • Will want to help.

All of those need to be true. Alternatively, you could still have all those points but replace the first with two others:

  • Someone who doesn’t use the Workflow but wants to take a stab at the problem.
  • They can reproduce your problem.


But even that second user (which sometimes is me) would rather have a response (or lack thereof) from the code’s author before committing time to debug foreign code. On the other hand, if you go to the Github page (good job posting it, that was useful for us to know what’s being talked about), you’re right at the source.

A Github issue and a comment on the original forum thread have roughly the same chance of success. In this case there’s no original forum thread, but there is a Github repository and the Workflow’s author has been active on Github this month. As I mentioned on the original post, it’s all about increasing your chance of getting it fixed.

Link to comment
  • vitor changed the title to [SOLVED] Deepl Workflow Problems
  • 8 months later...
  • 5 weeks later...

It's the default fallback action from Alfred App. Looking into the settings of "Default Results", the answer is "Fallbacks are shown when Alfred is unable to find any results...."

The script seems to be failing and the result will be NULL -> Alfred Fallback. Start the debugger and you will see what's going on.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...