Jump to content

[spacebar] as workflow keyword?


Recommended Posts

Curious, is it possible to trigger a workflow using [spacebar] as a keyword? I've always wanted to assign my own workflow to the cmd-space-space combo that Quick Search offers, but I can't seem to get it to work as seamlessly. Here are my steps to reproduce, what am I doing wrong?

 

1. First I enable Quick File Search

229342559_ScreenShot2021-09-07at6_05_35PM.thumb.png.832832b9540fdc8c623e93516e02b26c.png

 

 

Then I create a basic workflow with `'` as a the keyword

1372699843_ScreenShot2021-09-07at6_06_03PM.thumb.png.20ab94c5812baa42b2f5d1888a226bdd.png

 

Then I activate alfred with cmd space, press space again and I'm presented with Quick Search and my workflow. 

2017131739_ScreenShot2021-09-07at6_07_56PM.thumb.png.90da0864a59fe1d17f5ffef69aa1bfc8.png

 

Is it possible to configure this so that the workflow "Spacebar trigger" activates immediately when I enter the keyword instead of presenting me with the option to quick search too? Right now if I want to drill right in to the "Spacebar trigger" workflow I need to press cmd-space-space-down-enter instead of a simple cmd-space-space

Link to comment
On 9/8/2021 at 12:15 AM, brapstallion said:

Is it possible to configure this so that the workflow "Spacebar trigger" activates immediately when I enter the keyword instead of presenting me with the option to quick search too?

 

It's not clear what you're asking.

 

Why don't you use a different keyword for your workflow if you don't want it to show up at the same time as Quick Search? Or a Hotkey to go directly to your workflow?

Link to comment

my command to evoke Alfred is cmd-space, naturally cmd-space-space would be the next easiest thing to remember/use to activate a workflow seeing as my finger is already on the spacebar and i’m not required to remember a different key command. i suspect Alfred already knows this because quick find is preconfigured to activate when pressing the spacebar. I want to override this precondition and use spacebar to activate my own workflow seeing as i don’t use quick find. 

Link to comment
  • 1 year later...

Hi @vitor & @deanishe - Closely related to this thread's topic, do you guys know if it's it possible to effectively create your own quick search mode by: (1) disabling the real Quick Search (Prefs > File Search > uncheck "Enable Quick File Search mode"), and then (2) setting up a File Filter whose keyword is just a space?

 

Every time I try this, Alfred automatically blanks out / removes the space in the keyword field of the File Filter (i.e., which you can tell by just reopening the File Filter ... and, of course, its lack of results).


In any case, while I love the simplicity of triggering a file search with a simple space bar tap, in Alfred, I'd like to refine the types of files that I see in the results. For instance, I really don't need to see "json" or "icon?" files in the default Quick Search results (any many others that I don't regularly interact with). Unfortunately, Alfred's "Don't Show" settings aren't terribly helpful for excluding this garbage either (... not garbage, just stuff I'd rather use file filters to locate). In short, I wish that Alfred would allow for more specific file type exclusions in its "Don't Show" settings, but until that happens, I'd love to just trigger my own file filter with a space-based keyword.

 

Thanks for any help you can lend!

Link to comment
9 minutes ago, Jasondm007 said:

setting up a File Filter whose keyword is just a space?

 

You don’t set it to space, you set it to '. Because when you have Quick Search enabled, that’s the character that gets output. Make sure your File Filter has with space disabled.

Link to comment
38 minutes ago, vitor said:

 

You don’t set it to space, you set it to '. Because when you have Quick Search enabled, that’s the character that gets output. Make sure your File Filter has with space disabled.

 

Thanks a ton, @vitor!! I tried that setup when troubleshooting, but I didn't realize that the trick was to actually leave Quick Search enabled. I just assumed the default results would still be there, but that doesn't appear to be the case. Thanks!!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...