Jump to content

Alfred not finding any folders or files.

Jay B

Recommended Posts

Hi there and thank you for any help,


I'm new to Alfred. Everything is working great on my MacBook Air.


On my Mac Mini (which is brand new), I have installed Alfred successfully and have the powerpack. Both machines are up to date with sonama.


The settings are as per the MacBook Air, Alfred has full disk access and access to iCloud.


When I press command space space, Alfred will only find applications and not folders/files. 


I have tried:


using the 'open', 'find' commands

revoking full disc access and access to iCloud and granting access again.

Shutting down mac and restarting.

Reinstalling Alfred.

Clearing Alfred cache.


As mentioned, is a little strange as the MacBook air and Mac Mini settings for Alfred are configured identically.


Any advice would be most appreciated.





Link to comment

@Jay B Welcome to the forum - and to Alfred :)


The best place to start when you're unable to find files is by dragging a few of them into the File Troubleshooter:



This tool is built into Alfred and will give you a set of green checkmarks and - if something's not quite right - some red crosses, letting you know how to troubleshoot the issue.


Following instructions should be fairly straightforward; You may just need to let your new Mac complete its first index if it's really brand new out of the box. Alternatively, you may need to rebuild the macOS metadata index (steps 5 and 6 in the link above).


If you need further help, please post the output of the File Troubleshooter for a few files, and we can help you from there onwards.

Link to comment

Thank you Vero, 


The Mac Mini is 2 weeks old.


I used the file troubleshooter as you suggested, and got this message:


Check MDQuery file search...

macOS did not return a match for this file in your search scope. Try resetting Alfred's Preferences > Features > Default Results > Search Scope > Reset... to "Reset to Full Disk"


I 'reset to full disk' and all is good! Thanks for your help, much appreciated 🙂

Link to comment
  • 5 months later...

I am following up on this one - I had the same issue.  I just upgraded to Sonoma, invested in Alfred 5.5.  Alfred 4 worked great and quickly found any file I was searching for but 5.5 finds nothing.   I turned all permissions on and even followed every instruction on this page; https://www.alfredapp.com/help/getting-started/permissions/ - including running terminal to reset permissions.  I am not sure what to do?


Again, I get nothing in my searches - which is the fundamental reason I purchased 5.5.  I almost want to go back to 4.0, but not sure it works with Sonoma.


Any suggestions for getting the search to work?





Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...