Jump to content

Clipboard view hotkey not using correct keyboard layout


eproxus
 Share

Recommended Posts

The keyboard shortcut used to show the clipboard viewer does not use the currently active keyboard layout (the normal Alfred shortcut seems to do this correctly). For example, when I have the dvorak layout selected, the shortcut set for the clipboard viewer still only reacts to qwerty letter locations.

 

What you were doing when the issue happened
Opening clipboard viewer.
 
Whether you were able to replicate it a second time by performing the same action
Yes.
 
Include any screenshots that might help us
None needed.
 
Include the Alfred version & build number you are using

2.3 (264)

 
Include your OS X version
OS X 10.9.4
 
Link to comment
Share on other sites

 

The keyboard shortcut used to show the clipboard viewer does not use the currently active keyboard layout (the normal Alfred shortcut seems to do this correctly). For example, when I have the dvorak layout selected, the shortcut set for the clipboard viewer still only reacts to qwerty letter locations.

 

OS X works by allowing hotkey registration by keycode, not by character, which means it's the physical location of the key which is registered.

 

If you want to use the same combo in its new location in Dvorak, clear the hotkey in Alfred's preferences and re-set it using the Dvorak keyboard. This location will now be remembered. Alternatively, you can keep using the same keyboard location as you did with Qwerty, so that you can keep using the same keyboard location regardless of which of your two keyboard layouts you're using.

 

Cheers,

Vero

Link to comment
Share on other sites

Hi, thanks for your reply!

 

Well, if everything worked on just key codes, this would work out of the box (but showing the wrong letter in the GUI). However, this is not the case. Picking the correct letter works as expected, but Alfred maps it to the wrong key code (presumably choosing the mapping from Qwerty instead of Dvorak). Are you saying Alfred only gets a key code from OS X when a shortcut is created, and maps it itself to a letter to display? If that is the case, that mapping should be done with the currently selected layout and not Qwerty.

 

Cheers,

Adam

Link to comment
Share on other sites

I'm moving this to [investigating], but Alfred should work by mapping your hotkeys to the physical location on the keyboard. You may get quirks where the key displayed in the preferences is incorrect if you are switching keyboard layouts lots, but the actual physical key to trigger the hotkey should always be the same.

 

Vero is going to get a few alternative layouts installed and have a look into this behaviour, but I know that there are other multi-keyboard users who this is working fine for (aside from the key displayed).

Link to comment
Share on other sites

Ok, think I maybe found the issue. As I never changed the shortcut, it was visually set to ⌥⌘C, but reacted to ⌥⌘J (on Dvorak). However, changing it and re-setting it to ⌥⌘C seems to work, now it reacts correctly. Perhaps this was the only issue?

Link to comment
Share on other sites

Ok, think I maybe found the issue. As I never changed the shortcut, it was visually set to ⌥⌘C, but reacted to ⌥⌘J (on Dvorak). However, changing it and re-setting it to ⌥⌘C seems to work, now it reacts correctly. Perhaps this was the only issue?

 

That sounds likely!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...