Jump to content

Default Screen not working properly (unclear description text) [Fixed 2.7 b382]


ScherzkeCks
 Share

Recommended Posts

Hi,

 

I have set Alfred under Appearance->Options to "default screen".

 

And I assume my default screen is the one i drag the menu bar on under system settings. But Alfred is still showing on the other screen. Neither reboot of Alfred nor a reboot of the whole system helps.

 

 

Greetings

 

Stefan

Link to comment
Share on other sites

Hi,

 

I have set Alfred under Appearance->Options to "default screen".

 

And I assume my default screen is the one i drag the menu bar on under system settings. But Alfred is still showing on the other screen. Neither reboot of Alfred nor a reboot of the whole system helps.

 

 

Greetings

 

Stefan

 

Which OS are you using? I've just tested this on this machine (10.9) and when Alfred's "default screen" is selected, Alfred shows on the screen where the menu bar is displayed in OS X's display settings... no need to reboot, the update is instant.

Link to comment
Share on other sites

Hi,

 

I have set Alfred under Appearance->Options to "default screen".

 

And I assume my default screen is the one i drag the menu bar on under system settings. But Alfred is still showing on the other screen. Neither reboot of Alfred nor a reboot of the whole system helps.

 

 

Greetings

 

Stefan

 

I've also had a test, this time on Yosemite;

- Default will show on your Mac's default screen (the one where the menu bar is shown if you look at your OS X Displays > Arrangement) and correctly changes from one to the other when the bar is dragged

- Mouse screen will follow your mouse and Alfred will show up on whichever screen your mouse is currently on

- Active screen (which only works for 10.9 and 10.10) will cause Alfred to show on the screen that currently has the in-focus app

 

If Default doesn't do this, could you check you haven't ticked the "Save position when dragging Alfred main window" box just above the position dropdown menu?

Link to comment
Share on other sites

Hi,

 

I have 10.10 installed. I don't have the Save position when dragging Alfred main window box activated. Tried changing the option to one of the other two (which work as intended) and then back to default but default still shows Alfred on the wrong screen.

 

I also tried changing the default screen of OsX to the external monitor and back but that didn't help either.

 

Thanks for your help!

Stefan

Link to comment
Share on other sites

Hi,

 

I have 10.10 installed. I don't have the Save position when dragging Alfred main window box activated. Tried changing the option to one of the other two (which work as intended) and then back to default but default still shows Alfred on the wrong screen.

 

I also tried changing the default screen of OsX to the external monitor and back but that didn't help either.

 

Thanks for your help!

Stefan

 

I've played with this a little more and it looks like there is a scenario where it will take the saved screen position over the "Show Alfred on" setting.

 

Could you select "Save position when dragging Alfred main window" and drag it onto the screen you would like it on... this is another way to achieve what you want.

Link to comment
Share on other sites

To reproduce:

 

With Show Alfred on "default screen".... Select "Save position when dragging Alfred main window", drag onto secondary monitor then deselect "Save position when dragging Alfred Main window".

 

Alfred will continue to show on secondary screen.

 

[moved into bug reports so as to investigate further]

Link to comment
Share on other sites

Almost,

 

Alfred will continue to show where dragged until dragged again. Then it is back to secondary screen.

 

I'm re-familiarising myself with the window position behaviour, and it looks like in "default screen" mode with "save position" unticked, you can drag Alfred to the screen you would like him to show on. He will then show in the position shown in the "Where he shows" appearance options pref on the last screen you selected. This seems to work as expected on 10.9 and 10.10, so it looks like the text needs to be updated to reflect this.

 

Is this the behaviour you are seeing?

 

Cheers,

Andrew

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...