Jump to content

raguay.customct

Member
  • Content Count

    708
  • Joined

  • Last visited

  • Days Won

    11

Everything posted by raguay.customct

  1. It would be nice if Alfred could eject volumes mounted by CloudMounter and Expandrive instead of having special workflows for them.
  2. Okay. I've been using Scriptarian, but I can't get it to produce stack binaries.
  3. Thanks. It is working now. What framework are you using for the automation. I love that it is getting services too!
  4. I've found this script to work better. If you don't have the application, the above scripts will not work as well. This script doesn't stop working if you don't have one of the applications. I've also have other file managers in the list. This is what I use for my Alfred Browser workflow. on pathFinderFile() set appname to "Path Finder" tell application appname set pathfinderselection to selection if pathfinderselection is missing value then display dialog "Nothing selected" buttons {"Oh, crud..."} default button 1 return end if set pathfinderpaths to "" repeat wi
  5. You need to recompile using static linking. It's requiring a dynalib that I don't have: Code 6: dyld: Library not loaded: @rpath/libswiftAppKit.dylib Referenced from: /Users/raguay/Dropbox (Personal)/Richard/rag/Alfred/Sync/Alfred.alfredpreferences/workflows/user.workflow.85FE278A-FF20-4A2A-919E-8DE7DC7D1C62/./menu Reason: image not found
  6. First, install Hammerspoon. Then run "hs:install" in the Alfred prompt. Whatever hotkey you assigned Alfred to, press that. The default is <command>+space. You should then be able to use the rest of the commands in the workflow. Have fun!
  7. Yes, I split up the repository to Afred 2 and Alfred 3. Here is the link to the latest: https://github.com/raguay/MyAlfred/blob/master/Alfred 3/TextSoapCleaners.alfredworkflow You can see all of the workflows at https://github.com/raguay/MyAlfred/
  8. Here is a quick and easy workflow to do what you want. You will have to assign the hotkeys for each one. It allows you to either open the current OSX selection or clipboard in either chrome, firefox, or safari. You can get it here: https://www.dropbox.com/s/8kkpcjbzr2sde05/Open URL with hotkey.alfredworkflow?dl=0 Examine it and you will see that it is very easy to create workflows like this. There was no programming involved. So, go and experiment.
  9. The workflow works great on Alfred 2 or Alfred 3. The latest version with things for Alfred 3 only can be downloaded from my GitHub account: https://github.com/raguay/MyAlfred/blob/master/Alfred 3/HammerspoonWorkflow.alfredworkflow. It is often easiest to download the whole repo and load the workflow you want to use. I'm not sure which version is on Packal right now (I haven't had time to update it there yet).
  10. The website does that automatically. It'n not suppose to on code blocks, but it does. I've requested the fix several times. But, you can get the files from the download. I always use a TextSoap cleaner to fix them.
  11. Just to let you know, my latest Alfred tutorial is now live: https://computers.tutsplus.com/tutorials/exploring-alfreds-latest-features--cms-27910
  12. I've been experimenting with a new theme and found these funnies. The rounded corner doesn't work for every situation. Some of the corners are still square for different areas (Alfred prompt, Alfred prompt with incomplete keyword, Alfred file browser, and Alfred's clipboard menu).
  13. Okay. I testing with a similar setup. It must be an interaction with some other program. I just closed every program other than Alfred (well, the best I can). It seems to work that way. There must be a program I've updated about the same time Alfred updated. Actually, I believe most of my program has updated. I'll track down the program that is interfering and give them a yell. Sorry, I just assumed it was the update since it happened at the same time. My bad.
  14. I just did a plain input box connected to a clipboard and the line set to ctrl. It doesn't post to the clipboard at all and shows absolutely nothing in the debugger. Therefore, you should be able to test it with that.
  15. Sorry. Been a little busy. I can't get the console or debug unit to show anything. This is a workflow I use everyday since Alfred 2 first edition when I wrote it. I haven't changed anything on it since Alfred 3.0 when I updated the scripts to use the environment variables. You can download it from my GitHub account: https://github.com/raguay/MyAlfred/blob/master/Alfred 3/s3cmdToolkit.alfredworkflow The s3c:list command lists all of the folders on Amazon S3 that it is setup for. When you select ctrl on one of them, it give the web address which it simply calculates with the S3 hea
  16. It is working for me, but this version has some of my workflows not working. My s3cmd workflow quit copying an output of a script to the clipboard. The debugger shows nothing coming out of the script box, but the script box unconnected to anything does have the proper output. Very weird.
  17. Since I often do not use the computer on weekends and holidays, it would be nice to have a threshold on number of uses to count in the statistics. That way, you don't get all those zero to the minimum threshold counted in the average usage per day. That would give a more realistic number for the average usages per day count.
  18. Oops...forgot to try that. Okay, it seems to be working. I just tried several that had problems. I'll repost if it pops back up.
  19. I have a snippet tied to the key sequence: ;etd The snippet has this: Another one done: {clipboard} The clipboard contains a long web site link. When the link is very long, the end of the link gets deleted and the beginning still has the ";etd" (or part of it).
  20. When will it be fixed? I writing a follow-up tutorial for Tuts+ with all the new things in 3.1 and 3.2. I really want this one to be in it as well. I would also like to use this with my Quiver Workflow. Thanks
  21. When the {cursor} macro is used in a clipboard paste (not a text expansion), the cursor doesn't make it to the point if {query} is after {cursor}, but does fine if the {query} is before {cursor}. The trace back isn't taking into account the size of the {query} string. Also, not sure if this was in the intent, but the {cursor} macro can't be inside the {query} from the previous action. This latter would be a preferred path of action.
  22. Okay, It is now working on the Mac Mini again. It just took an hour to start up with the text services enabled. But, when I quit and restart it, it acts just like normal. I downgraded Alfred on my Mac Air, turned off text services, and upgraded. It still did not launch. I do share the preferences between the two Macs using Dropbox sync. Therefore, it must be something that doesn't get shared and having to do with Text Services. The Mac Air never runs the Text Services helper program when upgraded and text services enabled. Currently, I have the Air downgraded and the Mac Mini running the lates
  23. It has something to do with the Alfred Text Service. I did not realize it wasn't turned on on my Mac Mini. After turning it on and relaunching Alfred 3, it now will not launch on either system. I launched Alfred Preferences by itself and disabled text services, but that did not help. Hopefully, this will give you enough information to track it down. If not, let me know what else to look for.
×
×
  • Create New...