Jump to content

1Password is not shown on clipboard even though it's not ignored [Fixed 3.4.1 b858 pre-release]


Recommended Posts

For some reason this stopped working for me. I can pinpoint when exactly but some updated ago. I specifically removed 1password from the ignore apps of Advanced tab of the Clipboard's preference but now nothing that I copy from 1Password is shown in the history regardless of this setting.


I tried resetting the setting and removing 1Password again. I even tried removing every single app there and still 1Password entries are not shown on the clipboard. I use this very heavily.


Any ideas?


OSX macOS Sierra 10.12.5 (16F73

Alfred v3.4 [850]

Link to comment
Share on other sites

@mescalito  1Password marks all passwords as concealed data, so they aren't copied by Alfred or other clipboard managers, where your password would then most likely be stored in plain text. The "Ignored apps" is a further way for users to add other apps they wish to ignore.


I may be stating the obvious, but saving passwords in plain text in Alfred's clipboard defeats the point of using secure password managers like 1Password, so it'd be best to add the testing sites' URLs to the 1Password entry for the login/password you want to use (one entry can contain multiple URLs where the same details can be used) or temporarily store your passwords in a plain text file while testing the sites in question. If you copy the password from a plain text file to Alfred, the password will be treated as simple text and will successfully copy to the clipboard.


You can then remove an item from Alfred's clipboard later by selecting it and using Function + backspace.



Link to comment
Share on other sites

@Vero thanks for the reply.


It's not just password that I copy from 1password, I have account numbers and a lot of different information that I normally use.


I understand the risks of copying the pw to the clipboard, but I am OK taking them. I am a developer and I have zillions of passwords other useful info and the whole purpose of a clipboard manager is to be able to go back to it quickly. 


But bear in mind that this functionality was actually working in previous versions, I am 100% positive on this. You do have 1password as one of the defaults ignore apps. Once I removed that everything I copied from 1password would carry over to alfred just fine. Something must have changed.

Link to comment
Share on other sites

  • Andrew changed the title to 1Password is not shown on clipboard even though it's not ignored [Fixed 3.4.1 b858 pre-release]

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...