Jump to content

Trello Workflow 1.6.1 [Updated 16/07/18]

Recommended Posts

On 8/14/2018 at 2:50 PM, gamell said:

First of all, thanks to @Miko and co. for this amazing workflow.

Just wanted lo let you all know that I made a small change to it to allow users to set defaults via environment variables for List, Label, Due date and Position. So, for example, if you want to always create your cards in the same list as I do, you can set it once and forget it. If you pass any list via the query, that will override the default as expected.

You can find this version here.

And I also opened a Pull Request to get this functionality in the original workflow by @Miko , which also has some instructions as to how to set the defaults.




Thank you @gamell


I merged your pull request. Added you to the credit, your instructions and increased the version number across everything. 


Really liking those default variables :)




Edited by Miko
Link to comment
  • 1 year later...
  • 1 year later...

Hello everyone,


This workflow stopped working on my end after I upgraded to Monterey. Anyone in the same situation ? 

I guessed it is linked to the fact that PHP is not handled natively by Monterey and I can't find a solution (I have limited technical knowledge). 

Has anyone found a solution ? 


Thanks again to the creator of this worklfow, it's been crucial for me to use the GTD method with Trello !


Link to comment
7 hours ago, Pete Bastille said:

I guessed it is linked to the fact that PHP is not handled natively by Monterey




7 hours ago, Pete Bastille said:

Has anyone found a solution ?


This should work:

  1. Install Homebrew.
  2. Install PHP (brew install php).
  3. Add to the top of the Run Script: export PATH="/opt/homebrew/bin:/usr/local/bin:${PATH}".

Link to comment
6 hours ago, Pete Bastille said:

Unfortunately even after doing the procedure described, it's not working on my end. I still get the same error


If the process was correctly followed, you should not be getting that error. What’s the output of these two commands, in a terminal?

echo "${PATH}"
which php

Also, if you export your modified Workflow I can take a look.

Link to comment

@Vitor, I found the issue. 

I had an issue with the PHP setup through Brew. I double checked the the logs from the PHP install with Brew and there was an error. 
I found people with similar issues on Stack Overflow and running the following two commands allowed me to install PHP properly : 

sudo mkdir -p /usr/local/Frameworks /usr/local/sbin
sudo chown -R $(whoami) /usr/local/Frameworks /usr/local/sbin


Now everything works ! 

Thanks a lot for taking the time to help me :) 


Link to comment
  • 1 month later...
  • 7 months later...

Super late reply, but this is no longer an issue with Alfred and the workflow

Alfred will automatically search for PHP install in the following directories.




Alternatively, you can still define your path in the script as suggested.

export PATH="/opt/homebrew/bin:/usr/local/bin:${PATH}"


Tested with macOS Monterey 12.5 on Apple Silicon, PHP and PHP@7.4 installed with Brew

Edit: Tested using Alfred 5.0.1

Edited by Miko
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...