Jump to content

Number + Command opens inconsistently in finder and navigation


Recommended Posts

When searching, Command+[Number] opens a folder in Finder (rather than navigate into the folder), even though in Alfred's preferences>File Search>Navigation,  "Use [return key] to open folders in Finder" is unchecked.


Strangely, when I run "Previous Path", the Command+[Number] navigates into the respective enumerated folder, which is the behavior that you'd expect. I tried checking and unchecking "Use [return key] to open folders in Finder" and restarting Alfred, but that doesn't resolve the issue.


Link to comment
Share on other sites

@jayhlee These are two different modes;

  • In Alfred's default results, Cmd + number actions the result (e.g. if it's an app, it'll launch the app, if it's a folder, it opens the folder, and if it's a custom search, it performs the search in your default browser)
  • In File Navigation mode (which is the mode you enter with the Previous Path hotkey), Enter navigates into the folder

As such, the preferences under File Search > Navigation only apply to the File Navigation mode.


If you want to navigate into a folder from Default Results, you can use Cmd + down to enter File Navigation mode and browse the contents of a folder.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...