Jump to content

Script Filter action not executed.


Recommended Posts

https://github.com/zjn0505/adb-alfred/issues/33#issuecomment-1132584599

I got this issue for my workflow that I cannot reproduce it myself.

It is a python3 workflow to utilize adb, the CLI tool used by all Android developers.

The issue reporter can trigger the first "List devices" Scripti Filter action to show connected phones.

When he selected one item to proceed to next Script Filter action "Show device optios", the workflow breaks, and Alfred panel disappears.

The log ends when second script filter prints: Queuing argument ''

I suggested him to replace the second script to the minimum function to add one hardcoded item, but it is still the same result.

The workflow lib is taken from a previous commit of https://github.com/NorthIsUp/alfred-workflow-py3
 

Link to comment
7 hours ago, xilopaint said:

@zjn0505 if you face any issues using my fork, please let me know.


I provided a temporary build with integration of your fork, it got same result from issue reporter that the 2nd Script Filter action not executed. Details in https://github.com/zjn0505/adb-alfred/issues/33#issuecomment-1133585666

 

I still see the log end at
 

adb[Script Filter] Queuing argument ''

 

 

I suppose the execution of 2nd Script Filter action should print

 

adb[Script Filter] Script with argv '(null)' finished

 


I am trying to build more features with your fork, as `background.py` is working now. I hope new version will change something.

Link to comment
Posted (edited)

The issue was reported upon 1.13.2 version in which I used NorthIsUp's fork.

Now I realize that it is a strange log in https://github.com/zjn0505/adb-alfred/issues/33#issue-1241951576

 

line 16, in <module> from .workflow import Workflow, manager File "/Users/dannysilva/Library/Application Support/Alfred/Alfred.alfredpreferences/workflows/user.workflow.0EEA15B4-F9EB-4477-9569-C03DD844B5B1/workflow/workflow.py",
line 25, in <module> import cPickle ModuleNotFoundError: No module named 'cPickle' 16:17:51 background.py:241 ERROR [__workflow_update_check] background runner failed with 1


Because actually in that version workflow.py is located under /scripts/workflow/workflow.py, also there shouldn't be cPickle used.

At that time I thought it was related to the known issue in the backgroud task when checking workflow update.
 

I have _workflow_update_check error with 1.13.2 version as well, but not from cPickle, and it was not fatal, I could still continue to use the reset functions in the workflow even with that error on my side.


I suggested to start workflow without checking updates by initiating with wf = Workflow3(), but still doesn't work. From the 1st video clip and logs attached, the behavior is workflow won't run the 2nd Script Filter action.

 

Even I suggested to remove everything in the 2nd Script Filter action and only add one hardcoded item. It still doesn't work. 

 

So I came here and asked in this thread.


As suggested here, I created a temporary version with xilopaint's fork.

But based on the first video clip in https://github.com/zjn0505/adb-alfred/issues/33#issuecomment-1133585666, the issue is still there. Alfred not proceeds to the second workflow action. It ended after Queuing argument ''

 

[10:09:28.311] adb[[Script Filter](alfredpreferences:workflows%3Eworkflow%3Euser.workflow.2C5DFC7C-6BF2-464B-9708-44D7FC92AFE4%3E86E0AE80-E859-4D5D-B15B-D8631B27C24D)] Queuing argument ''



 

@dcdanny85 Sorry I still cannot reproduce this issue.

 

I have created a new release https://github.com/zjn0505/adb-alfred/releases/tag/v1.13.3, in which I fully migrated to xiloplant's library.

 

I have been using this workflow nearly a hundred times a day and cannot tolerate it doesn't work at all, so I do hope I can unblock the issue for you.

Again, now I saw the strange log your have. Maybe you can delete the workflow, and delete ~/Library/Caches/com.runningwithcrayons.Alfred/Workflow Data/xyz.jienan.adb/ folder, and re-import 1.13.3 version to see if it helps or not.

 

Edited by zjn0505
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...