Jump to content

Abnormal display of results when searching and in Universal Actions


Recommended Posts

Hi Alfred team!


I recently came across an abnormal display when typing something in Alfred, basically there will be some annoying blank area at the top of the search results when doing a random search and at the top of the window when using Universal Actions.


These blank spots will disappear in a few seconds, making the texts below them jumping up and down (because blank spots appear and disappear as I type.)  This happens a lot more frequently when I set more visible results.


Please see attachments.





I tried a few attempts like disable workflows, tuning appearance etc ..  I still do not know what could be the cause.


I would really appreciate it if you could help with this!

Link to comment

Thanks for your message and your attention into this issue.


I am using:

- macOS Sonoma Version 14.0 (23A339)which was pushed on Sep 13th.

- Alfred 5.1.2 [2145]

- I am not in a virtual machine and using my M1 Macbook Pro.


Other information might be related: 


The problem on the default search page and on universal control happen when I set results display to higher number such as 9, If I set to results display to 5, the problem seems to disappear, but this is still not ideal.


The Universal control bug was triggered when selecting anything and type in some random 'word' without result.


Hope this helps, Thanks for look into this.

Link to comment

@yinan What is your screen configuration? Are you working directly on your laptop screen or are you connected to one or more external screens?


Also, could you please confirm which Alfred theme you're using?


We are on the same Sonoma build, and have been unable to replicate this. We're very keen to work out in what scenario this quirk can be seen, so any additional information about your configuration would be helpful. :)

Link to comment

@Vero Thanks! I am working directly on my laptop screen (14 inch) with 1352 × 845 resolution.


I am using this theme, https://www.alfredapp.com/extras/theme/SF7ZcvDGDt/. However, I don't think this is because of themes, since the same issue is still there with default Alfred theme. please see the screenshot below.


One thing I need to note though, it is an occasional but frequent bug, meaning it cannot be triggered everytime, but it is still quite frequent. 

CleanShot 2023-09-18 at 11.18.09@2x.png

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...