Jump to content

Feature Request: Open in PathFinder


Recommended Posts

As with version 1, Alfred simply tells OS X to open a given path and OS X uses the default Finder app. This can be Finder, PathFinder, Total Finder, etc... So you need to set Path Finder as your default Finder replacement.

 

It's possibly that you'll need to restart/log out to ensure OS X is fully aware that you want to use PathFinder, but Alfred will then respect that default :)

Link to post
Share on other sites
  • 4 weeks later...

I'm having the same trouble. Oddly, it just seems to be a problem with the 'Reveal in Finder' workflow item. If I search for or browse to a folder in Alfred 2 and hit return, it reveals the folder in Path Finder as I'd expect. If I make a workflow with 'Reveal in Finder' it always reveals in Finder not Path Finder. It's the same with files or folders selected. I rebooted to make sure it wasn't something odd, but that didn't fix it.

Link to post
Share on other sites

I'm having the same trouble. Oddly, it just seems to be a problem with the 'Reveal in Finder' workflow item. If I search for or browse to a folder in Alfred 2 and hit return, it reveals the folder in Path Finder as I'd expect. If I make a workflow with 'Reveal in Finder' it always reveals in Finder not Path Finder. It's the same with files or folders selected. I rebooted to make sure it wasn't something odd, but that didn't fix it.

 

Ditto.

 

I just ran into this issue this past week as I've been waiting until I could get decent Dropbox and Droplr workflows in place before switching.

Link to post
Share on other sites
  • 1 month later...

I'm experiencing this as well.

 

Some Notes:

1) Every other app opens in PathFinder correctly

2) If you type in ~ and then go to a directory and hit Cmd+O it correctly opens that folder PathFinder

3) If you type in ~ and navigate to a file and choose "Reveal in Finder" it incorrectly opens Finder

4) If you have a workflow that does an "Open File" action on a folder, it incorrectly opens Finder

 

 

I feel this should possibly be moved to bug reports as it's supposed to be working correctly, but isn't.

Link to post
Share on other sites

This behaviour is actually controlled by PathFinder which modifies Alfred's settings files to intercept the system calls for opening and revealing in Finder. Other users have reported quitting Alfred, then unticking and reticking PathFinder's option to be the default file manager, then rebooting fixes the issue

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...