Jump to content

I can no longer search Google Drive from Alfred [Fixed 2.6 b372]


karlalfred
 Share

Recommended Posts

A few days ago, Google launched its new interface for Google Drive. Since then, I can no longer use Alfred to search Google Drive, because when I search for, say, "company folder" it inserts the text "company%20folder" into Google Drive's search box. (In other words, it inserts the text as HTML entities.)

 

Any idea how I can fix it?

 

I'm using v2.3(264) on up-to-date OSX Mavericks.

Link to comment
Share on other sites

A few days ago, Google launched its new interface for Google Drive. Since then, I can no longer use Alfred to search Google Drive, because when I search for, say, "company folder" it inserts the text "company%20folder" into Google Drive's search box. (In other words, it inserts the text as HTML entities.)

 

Any idea how I can fix it?

 

I'm using v2.3(264) on up-to-date OSX Mavericks.

 

I can't reproduce this issue (but I may be still seeing the old Google drive interface)

 

Could you let me know the URL you are seeing in the browser's address bar when you launch 'company folder' from Alfred... could you also search from within Google drive itself and let me know the URL.

Link to comment
Share on other sites

Hi Andrew,

 

Thanks for looking into it.

 

You'll know if you have the new Google Drive, because its left-hand menu will look like this: http://screencast.com/t/nC3nc7eCd

 

When I searched for company folder from Alfred, the URL was

 

https://drive.google.com/#search/company%20folder

…which redirected to…

https://drive.google.com/a/conversion-rate-experts.com/#search/company%20folder

…which redirected to…

https://drive.google.com/drive/u/0/#search/company%20folder

…which redirected to…

https://drive.google.com/drive/u/0/#search?q=company%2520folder

 
When I searched for the same phrase from within Google Drive, it resolved to this URL:

https://drive.google.com/drive/u/0/#search?q=company%20folder

 
I'd be happy to screenshare with you if you think it would be useful.
 
Karl
Link to comment
Share on other sites

Thanks for the URLs, I'll take a deeper look into this.

 

For now, disable the built in Google Drive search and create a custom URL for the .../drive/u/0/#search?q={query} URL instead and things should work fine again!

 

Cheers,

Andrew

Link to comment
Share on other sites

  • 3 weeks later...

Thanks, Andrew. How do I do that?

 

Incidentally, the custom search that I created has stopped working, and I can't work out why.

 

To update to the pre-release, go to Alfred's Updates tab and choose "pre-releases" from the dropdown at the bottom. Alfred will then let you know that there's a new version you can download.  Note that pre-releases are more frequent around release time, so you'll get a few notifications of updates. You can revert to just getting the general updates later if you prefer :)

 

If you post your custom search, we'll be able to take a look - but do try the Google Drive search in 2.5 first.

Link to comment
Share on other sites

Thanks, Vero. I'm now on v2.5. The official Alfred version doesn't work for me, nor does my own. As a workaround, I've written a search query that queries the old Google Drive interface, and that works fine.

 

I'd be happy to screenshare if you think it would be useful. Or maybe I'm the only one who's having this problem.

Link to comment
Share on other sites

Thanks, Vero. I'm now on v2.5. The official Alfred version doesn't work for me, nor does my own. As a workaround, I've written a search query that queries the old Google Drive interface, and that works fine.

 

I'd be happy to screenshare if you think it would be useful. Or maybe I'm the only one who's having this problem.

 

If you search Google Drive and perform a search within GD, what URL do you see? This information should help us get to the bottom of the issue. You can email us on info@alfredapp com if you would prefer, in case it contains any personal details you'd rather not post on the forum.

Link to comment
Share on other sites

  • 2 weeks later...

Hi! I've upgraded to the pre-release, but am still unable to search Google Drive either through the built-in web search or through the custom option noted above. In both cases, I briefly get the following generic search URL:

 

https://drive.google.com/drive/#search

 

Which quickly resolves to:

 

https://drive.google.com/drive/#my-drive

 

Which just lands me on the main page for my Drive account.

 

Thanks in advance for anything you can do to help!

Link to comment
Share on other sites

There seems to be a few issues in the Google Drive search URLs / redirection itself, so I'm leaving it as a bug for now and reverting the change I made.

 

Essentially if you do a search in the [new] Google Drive, then copy the URL and paste it back into a new browser tab, Google redirects your search query away... e.g. this is the URL when searching for "chicken nuggets" within google drive:

 

https://drive.google.com/drive/u/0/#search?q=chicken%20nuggets

 

yet clicking that redirects me through a few things then back to:

 

https://drive.google.com/drive/u/0/#my-drive

Link to comment
Share on other sites

Same issue here glad it is under review (Alfred 2.5 [299]).

 

If I search for "wish list" urls redirect like this:

 

1. https://drive.google.com/#search/wish%20list

 

2. https://drive.google.com/drive/#search/wish%20list

 

3. https://drive.google.com/drive/#search?q=wish%2520list

 

And the search input field displays "wish%20list". I just disabled and created a custom search for now.

 

Hope this helps,

Mike

Edited by mrm312
Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...