Jump to content

Alfred doesn't load settings from Dropbox folder


sendoa
 Share

Recommended Posts

v2.0 (166) on OS X 10.8.2

Dropbox v2.0.0

 

Whenever I restart my computer I have to enter my settings again because Alfred doesn't load them. I know he saves them. I've my settings  on a Dropbox folder located on a second hard drive: "/Volumes/Almacen/Archivos de Sendoa/Dropbox/Aplicaciones".

 

If I set de sync folder to (for example) my desktop, the problem disappears and the settings get saved and loaded correctly.

 

The strange thing is that whenever I set Alfred to sync with my Dropbox folder and I change any settings, I can see the Dropbox menu bar icon showing that something is being updated in Dropbox. So the problem seems to affect the settings loading process.

 

For example, if I set Dropbox to hide the hat icon nor the menu bar icon, I see that "/Volumes/Almacen/Archivos de Sendoa/Dropbox/aplicaciones/Alfred.alfredpreferences/preferences/appearance/options/prefs.plist" gets updated with the following contents:

 

 

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>hidehat</key>
    <true/>
    <key>hidemenu</key>
    <true/>
</dict>
</plist>
 

But if I quit and restart Alfred, it ignores those settings and the hat and menu bar icon are back. The settings file maintains the same contents after Alfred has restarted.

 

Same problem with "Features" settings tab. I cans see that my custom searches are saved but they aren't loaded back. The workflows instead are loaded correctly.

 

Thank you!

 

Link to comment
Share on other sites

v2.0 (166) on OS X 10.8.2

Dropbox v2.0.0

 

Whenever I restart my computer I have to enter my settings again because Alfred doesn't load them. I know he saves them. I've my settings  on a Dropbox folder located on a second hard drive: "/Volumes/Almacen/Archivos de Sendoa/Dropbox/Aplicaciones".

 

 

Did you allow Alfred on your primary Mac to fully sync before setting up any secondary macs, as there may be a Dropbox sync conflict causing this issue.

 

It could also be a permissions issue preventing Alfred from persisting the com.runningwithcrayons.Alfred-Preferences.plist file. It might be worth quitting Alfred and deleting these two preferences files in your home folder:

 

~/Library/Preferences/com.runningwithcrayons.Alfred-2.plist

~/Library/Preferences/com.runningwithcrayons.Alfred-Preferences.plist

 

then restarting Alfred and re-setting back up syncing. It might also be worth setting the sync folder to something outside of Dropbox to see if that was the issue (e.g. Documents folder).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...