pstadler

Screen Sharing with automatic network discovery

74 posts in this topic

Great. Thanks a lot.

But didn't work well for me.

Name of my MacBook ist "MacBook Air"

But I have to connect with "MacBook-Air.local"  see the -

Have no Idea what this is about.  :(

Share this post


Link to post

I've got a Mac Mini and 15" MBP (MBP-15) that i'm trying to access from my 13" MBP (MBP-13) using this workflow.  My Mac Mini shows up when typing "vnc" in Alfred v2, but not the MBP-15.  I can connect to the MBP-15 via vnc://IP address via Connect To Server fine.

 

Is there a setting I need to adjust in the System Preferences on the MBP-15 to get it be seen on the MBP-13 (the computer running Alfred v2).

 

Mac Mini and MBP-15 are running 10.7, MBP-13 is running 10.8

 

Thanks

Share this post


Link to post

Doesn't work for me too :(

Mac is called "alex-macmini.local" but alfred is trying to connect to alexmacmini.local and it doesn't work

Share this post


Link to post

Is there a chance that the download link is the old one? Tried re-installing, same

Also, my own machine appears in the vnc list, maybe it'll be good to remove the machine I'm on

Share this post


Link to post

Great workflow, very helpful. One thing that might be nice would be if it would show .local hosts before .icloud (i.e. Back To My Mac) hosts, but it doesn't make a huge difference imo :) Thanks!

Share this post


Link to post

Great workflow, very helpful. One thing that might be nice would be if it would show .local hosts before .icloud (i.e. Back To My Mac) hosts, but it doesn't make a huge difference imo :) Thanks!

 

I couldn't verify if this really works, but Alfred is supposed to learn what items you use most and move them to the top of the list.

Share this post


Link to post

It worked perfectly for me! So-o helpful! Thanks for an excellent utility for the new Alfred. I'll be using this every day! 

Share this post


Link to post

2013-03-16_08-43-21.png

 

Also, typing VNC 99.9.9.99 (simply masking my actual IP in the forums) launched Screen Share, but said the IP was wrong and showed 999999 in the  As soon as I added the decimal in the IP address, it took me to the Screen Share of the MBP-15

 

2013-03-16_08-36-10.png

 

 

Connection failed to “999999”.

Please make sure that Screen Sharing (in the Sharing section of System Preferences) is enabled on the computer to which you are attempting to connect. Also make sure your network connection is working properly.

 

2013-03-16_08-38-06.png

 

OS 10.8.3

Share this post


Link to post

@harrigg: I just updated the workflow to not escape the manual input (in your case the IP) anymore. This makes more sense than the way it worked before.

 

About your other problem. Please open Terminal.app and run the following command:

dns-sd -B _rfb._tcp

It sould immediately return a result like this:

Browsing for _rfb._tcp
DATE: ---Sat 16 Mar 2013---
15:02:47.020  ...STARTING...
Timestamp     A/R Flags if Domain                    Service Type              Instance Name
15:02:47.021  Add     3  5 local.                    _rfb._tcp.                Daedalus
15:02:47.021  Add     2  5 local.                    _rfb._tcp.                Brainbug


Press Ctrl+c to quit it. If MBP-15 is not listed there, then there's a problem with the service discovery for MBP-15 in your network. Are you using the default screen sharing service on this machine? Also, are you able to connect to the MacMini with the workflow?

Share this post


Link to post

No MBP-15 doesn't show up in the terminal script, will have to investigate that.

 

Your latest fix allowed me to access via "vnc 99.9.9.99" to MBP-15

 

I actually hadn't tried the MacMini before, but no I can't connect.  I also haven't checked the settings on that machine.

 

Thanks for the quick response and the assistance.   :)

Share this post


Link to post

@pstadler - what about my other suggestion? Hide the mac I'm working on from the list? It seems strange that I have the option to control my own mac?

Share this post


Link to post

@pstadler - what about my other suggestion? Hide the mac I'm working on from the list? It seems strange that I have the option to control my own mac?

 

Your own host should not be listed. Please help me figure out what's wrong.

Open Terminal.app and run the following command:

hostname && dns-sd -B _rfb._tcp

Post the output here.

 

Thanks

Share this post


Link to post
18:30:26.651  ...STARTING...

Timestamp     A/R Flags if Domain                    Service Type              Instance Name

18:30:26.651  Add     2  4 local.                    _rfb._tcp.                new_macmini (that's the host I'm on)

Share this post


Link to post

This is a really great workflow, thanks!

 

Is there a way to filter out the name of the machine on which I'm working at the moment? I can't imagine a situation where I would want to VNC to my local machine. In fact with the current version of the workflow I see several identical entries for my local host, it would be nice to only have one.

 

Glenn.

 

Share this post


Link to post

Make sure that you're having the latest version. Just use the download link in the first post.

 

If this doesn't help, please open Terminal.app, run the following command and post the output here.

 

hostname && dns-sd -B _rfb._tcp

Share this post


Link to post

Really nice, thanks.

 

However, I rarely connect to local machines, it would be really nice if you could read the list of favorite vnc servers out of ~/Library/Preferences/com.apple.sidebarlists.plist and include them in the results.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now