Jump to content

Chromium Bookmarks and History Search


Recommended Posts

  • 1 month later...
  • 2 months later...
  • 5 months later...
  • 1 year later...
9 minutes ago, 40-02 said:

@Acidham, thanks for your workflow! I use it quite often. 

Can you please consider such feature request: to add the keyword which will list results sorted not by number of visits, but by recency - when the url was visited last. 

I believe it can be handy. 

 

You mean triggered by a separat keyword e.g. `bhs` which sorts based on recently visitied?

Link to comment
  • 9 months later...

Upgrade Workflow:

  • Added ability to ignore URLs in history with a certain domain
  • Added Alfred 5 “configure workflow” feature to set up env variables
  • Performance improvement when caching favicons
  • Remove support for Firefox Browser

GitHub Release

Link to comment
  • 3 weeks later...

Hi @Acidham - I've been using this workflow for a while now and really appreciate it. Recently (and I'm not sure if this is associated with moving to Alfred 5 or v3.x of the workflow) the workflow has stopped working for me (i.e. no results returned).

 

Alfred sometimes (seems to be inconsistent & I'm not sure how to reliably recreate) now returns the following error:

Quote

 

Unable to run task!

Reason: working directory doesn't exist.

 

/bin/bash

 

Check that the selected language exists on your system.

 

If you're syncing Alfred's preferences, also check that all related workflow files exist locally.

 

Related Workflow Info...

Name: 'Chromium Bookmarks and History Search'

Folder:/Users/gordonbazeley/src/gjb/alfred/Alfred.alfredpreferences/workflows/user.workflow.39ACD55A-6B54-4EF0-B23F-3E13AD9E34EF

 

... any ideas on how to resolve please? I tried changing /bin/bash to /bin/zsh with no change in behaviour

 

Many thanks,

  Gordon

Link to comment

Thanks @Acidham In terminal I get the following

Quote

$ where bash
-bash: where: command not found
$ locate bash

WARNING: The locate database (/var/db/locate.database) does not exist.
To create the database, run the following command:

  sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.locate.plist

Please be aware that the database can take some time to generate; once
the database has been created, this message will no longer appear.

$ which bash
/opt/homebrew/bin/bash

The last command returns the same result after

chsh -s /bin/bash

 

I'm getting the same (lack of) result with the new version I'm afraid i.e. 

image.thumb.png.72ab6728365cbf7bcb299d64593dcecd.png

Link to comment

I changed to shebang to /bin/zsh. Therefore, what result do you get with where zsh?

What macOS version are you using? Even /bin/bash/ should be available at least.

Link to comment
3 hours ago, Acidham said:

I changed to shebang to /bin/zsh. Therefore, what result do you get with where zsh?

What macOS version are you using? Even /bin/bash/ should be available at least.

I'm using 12.3.1.

 

I deleted the workflow and reinstalled ... and now it's working fine. Thanks again for your help 🙂

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...