Jump to content
Hervé

Visual artifacts when changing appearance [Workaround Available]

Recommended Posts

Hi,

As you can see on the images, I have graphical glitches with all the Alfred's appearances (but not with Alfred Classic).

 

plxz9rtl.png

wtUiAk6M.png

o5KZZMFL.png

 

I'm running 4.0.4 (I also tried 4.0.5) on Mojave (10.14.6).

Any ideas?

Thanks

 

 

Share this post


Link to post
Share on other sites

@Hervé Are you running VLC? There's a bug between macOS and VLC, which can be seen occasionally in Alfred and in macOS native pop-up menus. If you quit VLC, the issue should go away.

 

Cheers,
Vero

Share this post


Link to post
Share on other sites

I'm having exactly the same behaviour when I'm working in Final Cut Pro - It looks like it might be something to do with GPU usage (my Mac has a separate GPU). If I minimise FCP and wait for a few seconds and then re-open Alfred, it works.

 

I didn't know that Classic would behave normally - just tried that now and it seems OK. Maybe it's something to do with transparency on some of the appearances?

 

I've tried disabling Automatic Graphics Switching and the issue keeps happening - maybe it's to do with how Alfred renders while something else is using the GPU?

 

Screenshot-2019-10-12-at-10-30-59.png

Share this post


Link to post
Share on other sites

Try duplicating the theme you'd like to use, setting the background opacity to fully opaque, and set the blur amount for the theme to 0.

 

Cheers,

Andrew

Share this post


Link to post
Share on other sites

Also, are you seeing visual artefacts on the macOS (top of the screen) drop down menus at the same time you're seeing them in Alfred?

 

Cheers,

Andrew

Share this post


Link to post
Share on other sites

Hi, I'm also having this issue whenever FCPX is running. On a Macbook Pro with GeForce GT 750M. As soon as I quit FCPX behavior is back to normal.

 

After reading through this thread where people were having similar issues but with VLC, I'm wondering if there's some rendering bug with Nvidia cards maybe? Like that thread, when I use a theme with no blur, the issues resolve.

 

In that thread it was suggested to contact VLC devs but it seems that either Apple or Alfred might be where the focus should lie (probably Apple, frankly).

 

 

IMG_0109.jpg

Share this post


Link to post
Share on other sites

Same problem here. On every appearance except Alfred Classic. I'm not running VLC. Doesn't matter what app I'm running the glitches always appear and render Alfred unusable.

Problems started with update too 4.0.5.

Share this post


Link to post
Share on other sites

@scottpie @LittlePaolo This is an issue that's very much in Apple's camp, as some users are seeing it in various apps like VLC, Final Cut, and even simply showing macOS menus on Macs where Alfred isn't even installed.

 

As suggested by Andrew, you can get around the issue as far as Alfred goes by duplicating the theme you'd like to use, setting the background opacity to fully opaque, and set the blur amount for the theme to 0.

  • To change the opacity, click the theme background and ensure that the opacity is set to 100% on the colour picker.
  • To change the blur, click the fuzzy circle icon in the top left of Alfred's Appearance preferences and set the blur to None.

Cheers,
Vero

Share this post


Link to post
Share on other sites
2 hours ago, Vero said:

@scottpie @LittlePaolo This is an issue that's very much in Apple's camp, as some users are seeing it in various apps like VLC, Final Cut, and even simply showing macOS menus on Macs where Alfred isn't even installed.

 

As the best thing to do is probably submit feedback to Apple since they'll need to be the ones to fix this, as developers do you have any recommendations to what we should put in the comments that might hit their "sweet spot" so to speak and get them to take it seriously?

Share this post


Link to post
Share on other sites

×
×
  • Create New...