Jump to content

Workflows / Alfred 5.5 Beta


Recommended Posts

macOS : Sonoma 14.4

Alfred : 5.5 (2555)




When I tried to update it using the Alfred gallery tab, it remained duplicated. 


I've also tested it by removing it and installing it manually, with the same result.
If you have a solution, please let me know.






Link to comment
Share on other sites

@GrimlocK Looks like you have two instances of the same ChatGPT workflow. Could you delete the disabled one? Or if it's there for a reason, change the bundle ID (by right-clicking it and choosing "Edit details".

Link to comment
Share on other sites

Hi @vitor


Thanks for the return. 


I'm not making any changes, except for the icons indeed.

I wanted to delete them and when I relaunch Alfred, it automatically reinstates them.


I haven't completely deleted the Alfred application and its files. If I can avoid it, but if I have to, then okay.




Link to comment
Share on other sites

@GrimlocK Could you please provide your Diagnostics file, which you can get by typing "?diagnostics" into Alfred? You can then email it to our info@ address, so that I can take a look at your sync configuration, as what you describe (trying to delete a workflow, and it comes back) sounds like Alfred doesn't have permission to make changes to the location where you've saved your preferences, or that a backup/sync service is reinstating files behind the scenes.



Link to comment
Share on other sites

@GrimlocK Taking a look at your Sync settings, I can see that you're using ~/Documents/Alfred Settings/ as the location for your preferences, which will be synced via iCloud.


First, quit Alfred and copy the Alfred.alfredpreferences file from your sync location to:
~/Library/Application Support/Alfred/


In the Application Support folder, delete the prefs.json file and relaunch Alfred.


In the Advanced Preferences, Alfred should now say that your preferences are not synced. Try using your preferences in this location, and see if you get normal behaviour in terms of updating workflows, removing duplicates, etc.


This takes iCloud out of the equation, and we can then set that back up next. :)

Link to comment
Share on other sites

@GrimlocK you aren't following Vero's instructions, which are to move your preferences back to the default location.


To reiterate and clarify:


1. Quit Alfred

2. Copy Alfred.alfredpreferences preferences from ~/Documents/Alfred Settings/ to ~/Library/Application Support/Alfred/

3. Delete ~/Library/Application Support/Alfred/prefs.json

4. Restart Alfred


Don't do anything further with your preferences.


Now delete the Chat GPT workflow and try installing fresh from the gallery.




Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...