Jump to content

Recommended Posts

  • 2 weeks later...
  • 1 month later...

Want to say THANK YOU @mannieschumpert. Excited about the potential for Asana Quick Task.


I'm an Asana power user, and Alfred newbie.


PROBLEM/ERROR: "workspace: Not an ID:"


I've set aproject target — using aproject and selecting the desired project from the pick list. See snapshot… http://jkorn.com/RIvw The system responds with Growl message: "Project-Name \(1234\) set as task target." Note: Project name has a parentheses, and the parentheses are escaped in the Growl message. But when I attempt to add a new task, targeted to the selected project, I receive a Growl message with an error: "workspace: Not an ID:" See snapshot…  



I've tried: Setting aproject target to a project name with no parentheses. No problems creating new tasks, no error messages.


Possible there's a bug affecting project names that include parentheses?


Thanks again for making Alfred so useful! I look forward to hearing your advice on this.

Edited by jk02478
Link to comment
  • 1 month later...

Thanks for this. It works great!

Unfortunately my work with asana mostly revolves around tagging tasks, adding comments, and viewing task details. That kind of functionality isn't available with this workflow right?

I'll keep eye on it to see if it will fit my needs in the future.


Link to comment


This is just my perception, but I think I'm right: there's no way an Alfred workflow can do those things more efficiently than using the Asana web interface.


It would be exceedingly difficult to program, and I believe the results would absolutely not increase productivity. So, I can say with almost 100% certainty that I won't ever even try to add those features. Sorry to disappoint.

Link to comment
  • 4 weeks later...

@mannieschumpert, thanks for building this great workflow! I am new to alfred powerpack and but I am a Asana power user and this is just making my life much easier! 


Congrats on becoming THE official workflow Alfred + Asana, you deserve it!

Link to comment

As I said, I am a newbie at Alfred and still trying to learn how to use more advanced features. I went through aspaces and choose the one I want it to send the tasks but when i enter a task it shows "Workspace: NOT AN ID"... what am I doing wrong?


Sorry to come with such a dumb question :/

Edited by V.A.
Link to comment

@mannieschumpert, you were right on the dollar! It is only happening when I choose a specific workspace. If I choose a project within that workspace, it works just fine as well as choosing another workspace. 


Could that be because I am using names that are not commonly used in English, i.e., Comunicação e Mídia? 




Link to comment

That is definitely the reason!


I didn't test for Portuguese when I built it. ;)


I see what is happening now, and probably can figure out a workaround. I'll keep you posted.


That would be great!  I am promoting the use of Alfred and Quick Tasks as much as I can among my friends (that have a mac :) ) and they all speak portuguese :D That is what happens when you leave in Brazil :P 


Thanks for putting so much effort on this!!!

Link to comment

I just downloaded this workflow yesterday and it was working fantastic until this morning? When I noticed my tasks were not showing up, I tried re-entering my API key and gave me this warning...


Warning: Invalid argument supplied for foreach() in /Users/xxx/Library/Application Support/Alfred 2/Alfred.alfredpreferences/workflows/user.workflow.xxx/asana.php on line 438


Any ideas for how to correct this or start over -- which BTW I have already tried?

Link to comment



What does "tasks not showing up" mean? Were you adding tasks with QuickTask, and they weren't showing up in the Asana app?


Also, that error is occurring because the Asana API is not returning any workspaces, which means either you don't have workspaces or there is a problem with your API key. The "tasks not showing up" problem would also support the possibility that there is a problem with your key.

Link to comment
  • 2 weeks later...

@Jonathan Ray:

After hearing a similar report via Twitter, it was revealed that the Asana API was temporarily out of service.



I worked on it a bit weekend before last, but there's some real peculiarities to the way Alfred was encoding/decoding JSON, which is why special characters get busted. I haven't found a solution, but Alfred has some new debugging features. Once I find time to explore those, I might be able to find a solution.

Link to comment

I've played with this some more and finally gave up and reinstalled both Alfred and your workflow. No luck unfortunately. I get this same warning when trying to set my api key "Warning: Invalid argument supplied for foreach() in /Users/xxx/Library/Application Support/Alfred 2/Alfred.alfredpreferences/workflows/user.workflow.xxx/asana.php on line 438."


FWIW, I'm on OSX 10.9.2, 2.7 GHz Intel Core i7

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...