Jump to content

A simple workflow with a hotkey turns the keyboard into weird symbols and characters [Fixed 3.1 b708 pre-release]


Keven
 Share

Recommended Posts

I just purchased Alfred 3. Liking it a lot, but whenever I create a simple workflow with a hotkey and a system command, the keyboard shortcut works, but as soon as I start typing something, it ends being a bunch of random symbols and characters.

 

Just tried it:

ªƒæߪƒæߪƒæߪ˙∆˚˙ ©æ∆ߪ©>∫æµ ªƒßæ /˚ƒ∫æ<

 

Almost all keyboard shortcuts stop working and I then need to log out my user from the Apple icon and then 'Log Out [user]' so the bug goes away.

 

Is there a way to fix this?

Link to comment
Share on other sites

The bug seems to have stopped. I'll give an update if it comes back.


 


 



You can make 2 more posts until 31 July 2016 - 04:18 PM. This restriction is in place until 06 August 2016 - 04:16 PM



 


Why is there a limit to posts I can make? I've been searching for hours for what I am trying to do. I then posted questions, thanked someone for the workflow that was shared and reported a bug. I paid for the application and it is apparent I am not here to spam. I am newly starting out with new features of Alfred, hence my questions. Could you please remove the new user spam block for my account?


Link to comment
Share on other sites

Yeah, it is doing it again. I have to log out and log back in every so often to be able to continue using Alfred workflows/keyboard shortcuts.

 

 

This is actually the same thing as the other bug in this forum:

 

http://www.alfredforum.com/topic/9050-keyboard-becomes-unusable-after-starting-up-workflows-in-alfred-301/

 

That thread gives a workaround, but if you pop an email to our info@ address, I'll share a beta build with a fix :)

 

Cheers,

Andrew

Link to comment
Share on other sites

This is actually the same thing as the other bug in this forum:

 

http://www.alfredforum.com/topic/9050-keyboard-becomes-unusable-after-starting-up-workflows-in-alfred-301/

 

That thread gives a workaround, but if you pop an email to our info@ address, I'll share a beta build with a fix :)

 

Cheers,

Andrew

 

 

Hi Andrew,

 

Thanks for the response. I sent you an email for the beta build. I would use the workaround, but the only options I have are 'Pass through to workflow' and 'Show Alfred' (no 'Pass through modifier keys (Fastest)' like mentioned in the thread).

 

Also, the is my last allowable post (get this message: You can make 1 more posts until Today, 04:18 PM. This restriction is in place until 06 August 2016 - 04:16 PM). Could you please remove the new user spam block on my account?

 

Regards.

Link to comment
Share on other sites

Hi Andrew,

 

Thanks for the response. I sent you an email for the beta build. I would use the workaround, but the only options I have are 'Pass through to workflow' and 'Show Alfred' (no 'Pass through modifier keys (Fastest)' like mentioned in the thread).

 

Also, the is my last allowable post (get this message: You can make 1 more posts until Today, 04:18 PM. This restriction is in place until 06 August 2016 - 04:16 PM). Could you please remove the new user spam block on my account?

 

Regards.

 

 

The option you are looking for is from the hotkey field itself as seen here (set it to "Pass through modifier keys"):

 

https://www.alfredapp.com/help/workflows/triggers/hotkey/#tips

 

I'm not currently at my development Mac, so I can't send you a beta build, you'll get this tomorrow :)

 

Vero will reply to your email regarding limits shortly.

 

Cheers,

Andrew

Link to comment
Share on other sites

The option you are looking for is from the hotkey field itself as seen here (set it to "Pass through modifier keys"):

 

https://www.alfredapp.com/help/workflows/triggers/hotkey/#tips

 

I'm not currently at my development Mac, so I can't send you a beta build, you'll get this tomorrow :)

 

Vero will reply to your email regarding limits shortly.

 

Cheers,

Andrew

 

Hey Andrew,

 

I didn't know about this option. I have tried it now and I think I see some difference. Would it be possible to set it as default? That is new hotkeys created will default to the 'pass through modifier keys' option.

Link to comment
Share on other sites

The option you are looking for is from the hotkey field itself as seen here (set it to "Pass through modifier keys"):

 

https://www.alfredapp.com/help/workflows/triggers/hotkey/#tips

 

I'm not currently at my development Mac, so I can't send you a beta build, you'll get this tomorrow :)

 

Vero will reply to your email regarding limits shortly.

 

Cheers,

Andrew

 

 

Ah, everything works now!

 

Thanks!

Link to comment
Share on other sites

I upgraded to the beta build and almost everything is working fine—although I don't know if it is because I switched almost everything to 'Pass through modifier keys (Fastest)'. However, it seems like there is one thing that is consistently causing the bug, every time and as soon as you use the workflow. That is 'Copy to Clipboard' with a hotkey (no matter if you switch it to 'Pass through modifier keys (Fastest)'). If it can be of any use, the modifiers I used to set these to are the ^ / ctrl and ⌥ / option modifiers. 

Link to comment
Share on other sites

I upgraded to the beta build and almost everything is working fine—although I don't know if it is because I switched almost everything to 'Pass through modifier keys (Fastest)'. However, it seems like there is one thing that is consistently causing the bug, every time and as soon as you use the workflow. That is 'Copy to Clipboard' with a hotkey (no matter if you switch it to 'Pass through modifier keys (Fastest)'). If it can be of any use, the modifiers I used to set these to are the ^ / ctrl and ⌥ / option modifiers. 

 

 

Could you post a link to the workflow or email it to us, and let me know exactly what hotkey combo you've set?

 

When setting hotkeys to "pass through modifier keys", Alfred passes the modifier key through so you may find that the behaviour you're seeing is exactly as expected if, for example, Alt is being passed through to an app that allows you to use the Alt key to select an alternative library (like Photos does).

 

It's difficult to tell based on the explanation, so we'll have a look as soon as we see your workflow :)

 

Thanks

Vero

Link to comment
Share on other sites

Could you post a link to the workflow or email it to us, and let me know exactly what hotkey combo you've set?

 

When setting hotkeys to "pass through modifier keys", Alfred passes the modifier key through so you may find that the behaviour you're seeing is exactly as expected if, for example, Alt is being passed through to an app that allows you to use the Alt key to select an alternative library (like Photos does).

 

It's difficult to tell based on the explanation, so we'll have a look as soon as we see your workflow :)

 

Thanks

Vero

 

 

Hi Vero,

 

I sent you an email with the subject as WorkflowsThatCauseBug with the workflows.

 

When I posted my previous comment, only the Copy to Clipboard action was causing the bug. Now, also some System Commands cause it. I deleted it but it was hotkey and System Command action (Sleep).

 

Regards.

Link to comment
Share on other sites

Hi Vero,

 

I sent you an email with the subject as WorkflowsThatCauseBug with the workflows.

 

When I posted my previous comment, only the Copy to Clipboard action was causing the bug. Now, also some System Commands cause it. I deleted it but it was hotkey and System Command action (Sleep).

 

Regards.

 

 

Alfred is essentially working as expected in this situation - this is why the option exists for simulating the release of hotkeys. Now that you have set these hotkeys to pass the modifiers through, it's as if you are holding those modifier keys during the workflow, and subsequent actions.

 

You'll need to set these back to simulate mod release for the subsequent actions to be treated as if you weren't holding down modifier keys.

 

Cheers,

Andrew

Link to comment
Share on other sites

Alfred is essentially working as expected in this situation - this is why the option exists for simulating the release of hotkeys. Now that you have set these hotkeys to pass the modifiers through, it's as if you are holding those modifier keys during the workflow, and subsequent actions.

 

You'll need to set these back to simulate mod release for the subsequent actions to be treated as if you weren't holding down modifier keys.

 

Cheers,

Andrew

 

 

Oh, okay. Cool. I'll give an update once I start adding new workflows with this setting.

 

Thanks.

Edited by Keven
Link to comment
Share on other sites

There were some workflows that the bug was happening, but there was one keyboard key that was creating the bug no matter the mode of the hotkey. It did the exact same thing using a similar but different application. So this wasn't due to Alfred, but rather because of the keyboard key.

 

 Maybe that can be useful to know. It was a non-English character, 'À'. It is situated on the key all the way to the right, and directly under the 'delete' key on MacBook Pro keyboards (13-inch).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...