DONSA

Alfred 3 Lock [Known Issue, Workaround available. Fixed macOS 10.12.3]

12 posts in this topic

Hi,

 

It seems to be a problem with the new MacOS Sierra when I have set the option to unlock computer with Apple Watch.
When I use Alfred option to lock the screen, it kills the current session and all the apps (like a reboot).

 

Thanks

Share this post


Link to post
Share on other sites

@DONSA This definitely doesn't sound right - I'll add a ticket to look into this for the next release.

 

For now, instead of using Lock (which suspends the user session, and could be causing the issue), use Screensaver with Password :)

 

Cheers,

Andrew

DONSA likes this

Share this post


Link to post
Share on other sites

@Amr We're already intending to investigate this for the next release :) Use Andrew's suggestion for now (Use the Screensaver with password required when coming back from screensaver mode)

Share this post


Link to post
Share on other sites

Hi,

 

I am also seeing this issue running Alfred 3.2 and macOS 10.12.1. It doesn't occur consistently but roughly once a week - I lock/unlock using alfred 5+ times a day. I am not using lock/unlock via an apple watch. I am entering my password on the lock screen.

 

When it occurs all the apps relaunch like logging in. In the terminal the command "whoami" returns the correct user name however I am unable to ssh to anywhere afterwards. I receive the error about the user not existing. Sorry I lost the error message in, I will post again the next time it happens. The only way to correct the problem once it occurs is to reboot.

 

Its almost like its starting a duplicate session of the same user rather then unlocking back into the locked user.

 

Let me know any other information I can provide. If it keeps happening I will try the screen saver option.

 

Thanks

 

Share this post


Link to post
Share on other sites

@DONSA it anything happens, it'll be removing the lock feature... the reason I haven't done this sooner is that it only affects a finite number of users.

 

My recommendation is still the same as above, use either the screensaver or sleepdisplays commands, and set macOS to require password on return.

 

Cheers,

Andrew

Share this post


Link to post
Share on other sites

It probably affects only users with the active "Allow your Apple Watch to unlock your Mac" feature.

It's sad that it will get removed, it's a great feature.

 

Share this post


Link to post
Share on other sites

@DONSA using my recommended method will still allow you to unlock with your watch.

 

The issue arrises in the fact that under the hood, the lock command actually suspends the macOS session which is what's possibly incompatible with something. You could even rename the 'sleepdisplays' command to 'lock' (with password required in the macOS Security & Privacy prefs) and it'll do the same job but without suspending the session.

Share this post


Link to post
Share on other sites

Good tip. The icon is not the same and the there is no cool transition, but I can live with that 😜

 

Thanks!

Share this post


Link to post
Share on other sites
2 hours ago, DONSA said:

It's working again after update macOS Sierra to the latest version (10.12.3).

 

Great, thanks for the update!

Share this post


Link to post
Share on other sites