Jump to content

[SOLVED] Alfred not showing up in Menubar and command key not triggering


ylluminate
 Share

Recommended Posts

Having a strange issue since the last few updates it appears. I had stopped using Alfred for some time due to previous problems, but now that I've come back over the course of the past week I'm finding that Alfred doesn't show up within the menubar (I use Bartender and hide Alfred on the secondary menubar) after some time of running. I've checked and the process is still running (`ps | grep Alfred` and in Activity Monitor.app), but seemingly unresponsive since also the keyboard command trigger (in my case control-^) does not evoke Alfred either. 

 

If I wait a bit, like a couple of minutes, Alfred finally pops up to allow text entry, but the menubar icon still stays gone.  I don't see the process showing up as being hung.

 

If I kill Alfred and then bring it back up by starting it again via Spotlight or running it otherwise (iTerm or Finder/Path Finder) things begin to behave normally again for a while - perhaps hours.

 

Something is definitely off, but not sure where to track down this issue yet.  Any useful logs or such perhaps that might indicate what's going on?

 

Link to comment
Share on other sites

@ylluminate What happens if you disable Bartender? This hasn't been reported by anyone else, so I'd be curious to hear what behaviour you see without Bartender.

 

Also, it would be helpful to state which version of Alfred and macOS you're using.

 

Cheers,
Vero

Link to comment
Share on other sites

  • 2 weeks later...

So after the last update the menubar issue seems to be gone... Alfred seems to be behaving properly again. I was running on the previous version of Bartender as well since the new beta will not run on Catalina and I won't be switching to Big Sur anytime soon since it breaks a lot of good things that cannot yet be addressed (such as DisplayLink support for my particular system).

Link to comment
Share on other sites

  • vitor changed the title to [SOLVED] Alfred not showing up in Menubar and command key not triggering

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...