Jump to content

ZotHero — Generate Zotero citations in Alfred

Recommended Posts

On 7/23/2023 at 11:49 AM, Faris Najem said:

It seems that the problem is only in the "date" field

yes, Zothero parses the date field to obtain date and year which are then used as needed across citation styles. Would you use the numerals to enter the year only, or more complex dates (month and year, full date etc)? If year only I can try to add a way to handle that. 

Link to comment
  • 5 months later...

I tried ZotHero 2.2 today. The installation seemed successful, and when I type "zot" into Alfred I see some ZotHero Alfred results appear. But when I add anything as a query, like "zot smith" or for that matter "zot s", Alfred just goes to my fallback search option. (This is Alfred 5.1.4, Zotero 6.0.3.)


Is there some set-up step that I'm missing?

Link to comment
  • 2 weeks later...

Ah, ok. Thanks @vitor. So when I type "zot S" (on my way for trying to search for "Smith") I get:


[14:53:55.042] ZotHero[Script Filter] Script with argv 'S' finished
[14:53:55.047] ERROR: ZotHero[Script Filter] Code 1: xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun


This same error recurs for like every part of the "Smith" string as I type it in.

Link to comment

Thanks Stephen_C! I've done so, and I'm now getting a different error:


[13:00:51.275] ZotHero[Script Filter] {
  "items": [
      "title": "Error in workflow 'ZotHero'",
      "subtitle": "[Errno 2] No such file or directory: '/Users/tobymartin/Zotero/better-bibtex.sqlite'",
      "valid": false,
      "icon": {
        "path": "/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/AlertStopIcon.icns"


I don't know whether "better-bibtex.sqlite" is supposed to be created on-the-fly, but I can confirm that there's no such file in my Zotero folder. I have instead "zotero.sqlite" along with some back-ups.

Link to comment
On 2/4/2024 at 10:36 AM, Tee Elem said:

Just to confirm, @rdjfraser's issue is exactly what I described in my Jan. 26 post. I'm using the version from the Gallery.


@giovanni how would I check the debugger? "zotconf Open Log File", per the GitHub page? That doesn't work for me. When I type "zotcon" into Alfred I see the first image. When I add an "f" I see the second image.


Screenshot 2024-02-04 at 09.35.06.png

Screenshot 2024-02-04 at 09.36.07.png


I installed from the gallery too. I did try this M1 troubleshooting video, and installed  php. The ZotHero workflow seems to be working now.



Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...